Bug 1324598 - hammer content view promote failed
Summary: hammer content view promote failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Zach Huntington-Meath
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1286523
TreeView+ depends on / blocked
 
Reported: 2016-04-06 18:01 UTC by sthirugn@redhat.com
Modified: 2019-09-26 16:21 UTC (History)
4 users (show)

Fixed In Version: rubygem-hammer_cli_katello-0.0.22.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:08:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14538 None None None 2016-04-22 16:36:00 UTC
Red Hat Bugzilla 1286523 None None None Never
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Internal Links: 1286523

Description sthirugn@redhat.com 2016-04-06 18:01:51 UTC
Description of problem:
hammer subscription upload timeouts

Version-Release number of selected component (if applicable):
Satellite 6.2.0-beta-snap2.1

How reproducible:
Always

Steps to Reproduce:
hammer> content-view version promote --content-view='rhel7cv' --organization-id=1 --to-lifecycle-environment='QE' --asyncCould not promote the content view:
  Error: found more than one lifecycle_environment


hammer> content-view version promote --content-view='rhel7cv' --organization-id=1 --to-lifecycle-environment-id=2
Could not promote the content view:
  Error: found more than one lifecycle_environment

hammer> content-view version promote --content-view='rhel7cv' --organization-id=1 --to-lifecycle-environment='QE' --from-lifecycle-environment='Library'
Could not promote the content view:
  Error: found more than one lifecycle_environment


Actual results:
Error as shown above

Expected results:
No error and successful promotion

Additional info:

Comment 2 sthirugn@redhat.com 2016-04-06 18:32:44 UTC
Also in the same box, hammer activation-key create failed:

hammer> activation-key create --name=testak1 --organization-id=3
Could not create the activation key:
  Error: found more than one lifecycle_environment

Note: please make sure to have multiple lifecycle environments

Comment 3 sthirugn@redhat.com 2016-04-06 18:41:27 UTC
For Comment 2, I got the following error in hammer debug mode:

[ERROR 2016-04-06 14:40:00 Exception] Error: found more than one lifecycle_environment
Could not create the activation key:
  Error: found more than one lifecycle_environment
[ERROR 2016-04-06 14:40:00 Exception] 

HammerCLIForeman::ResolverError (found more than one lifecycle_environment):
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/id_resolver.rb:209:in `pick_result'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/id_resolver.rb:168:in `find_resource'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/id_resolver.rb:143:in `get_id'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/id_resolver.rb:133:in `block (2 levels) in define_id_finders'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_katello-0.0.22.5/lib/hammer_cli_katello/id_resolver.rb:52:in `environment_id'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/commands.rb:153:in `get_resource_id'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/commands.rb:222:in `block in customized_options'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/commands.rb:219:in `each'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/commands.rb:219:in `customized_options'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/commands.rb:243:in `request_params'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.4/lib/hammer_cli/apipie/command.rb:43:in `send_request'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.5.1.3/lib/hammer_cli_foreman/commands.rb:189:in `send_request'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.4/lib/hammer_cli/apipie/command.rb:34:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.4/lib/hammer_cli/abstract.rb:22:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/subcommand/execution.rb:11:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.4/lib/hammer_cli/abstract.rb:22:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/subcommand/execution.rb:11:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.4/lib/hammer_cli/abstract.rb:22:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:133:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.5.1.4/bin/hammer:125:in `<top (required)>'
    /usr/bin/hammer:23:in `load'
    /usr/bin/hammer:23:in `<main>'

Comment 4 Zach Huntington-Meath 2016-04-07 21:17:16 UTC
Created redmine issue http://projects.theforeman.org/issues/14538 from this bug

Comment 5 Bryan Kearney 2016-04-07 22:13:33 UTC
Upstream bug component is WebUI

Comment 6 Jitendra Yejare 2016-04-12 13:42:11 UTC
I hit the same issue of multiple environments while attempting hammer repository list.

#hammer repository list --organization-id 1
Error: found more than one lifecycle_environment

Comment 8 Roman Plevka 2016-04-18 15:16:53 UTC
VERIFIED
sat 6.2.0 snap 8.2

hammer> content-view version promote --content-view='rhel7cv' --organization-id=1 --to-lifecycle-environment='QE' --async
Content view is being promoted with task 54f9fc4f-48d6-420c-968d-474fe8205bce


hammer> repository list --organization-id 1
---|-----------|--------|- -|-----------------------------------------------
ID | NAME | PRODUCT | CONTENT TYPE | URL   
---|-----------|--------|---|-----------------------------------------------
7  | Satellite 6 Tools        | satellite-beta   | yum | http://<hostname>/pulp/repos/Sat6-CI/QA/Tools_RH...
6  | Satellite 6 Capsule      | satellite-beta   | yum | http://<hostname>/pulp/repos/Sat6-CI/QA/Capsule

Comment 10 errata-xmlrpc 2016-07-27 09:08:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.