Bug 132460 - ksh should obsoletes ksh93
Summary: ksh should obsoletes ksh93
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ksh   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-13 17:23 UTC by Brian Long
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 22:09:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Long 2004-09-13 17:23:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040815

Description of problem:
There has been a publicly available "ksh93" rpm for years.  Many folks
have replaced "pdksh" in RHEL 3 with the ksh93 rpm.  Since Red Hat
chose to include ksh-2004 in this update, please update the SPEC file
to "Obsoletes: ksh93".  This way your ksh RPM provides a proper
upgrade path from the older public-domain ksh93 RPM.  Thanks!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh ksh*.rpm
2.
3.
    

Actual Results:  File conflicts with ksh93 RPM.

Expected Results:  Upgrades ksh93 to ksh.

Additional info:

Comment 1 Karsten Hopp 2004-09-13 22:09:08 UTC
fixed in the next version, thanks 


Note You need to log in before you can comment on or make changes to this bug.