Bug 1324620 - Subnets -> Capsules -> `Discovery Proxy` should be renamed to `Discovery Capsule`
Summary: Subnets -> Capsules -> `Discovery Proxy` should be renamed to `Discovery Caps...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-06 19:36 UTC by sthirugn@redhat.com
Modified: 2019-09-26 16:21 UTC (History)
5 users (show)

Fixed In Version: rubygem-foreman_discovery-5.0.0.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:31:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (99.08 KB, image/png)
2016-04-06 19:36 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14589 None None None 2016-04-22 16:18:15 UTC

Description sthirugn@redhat.com 2016-04-06 19:36:43 UTC
Created attachment 1144345 [details]
Screenshot

Description of problem:
Subnets -> Capsules -> `Discovery Proxy` should be renamed to `Discovery Capsule`

Version-Release number of selected component (if applicable):
Satellite 6.2.0-beta-snap2.1

How reproducible:


Steps to Reproduce:
N/A

Actual results:
See screenshot

Expected results:
`Discovery Proxy` should be renamed to `Discovery Capsule`

Additional info:

Comment 2 sthirugn@redhat.com 2016-04-06 19:39:01 UTC
Also the description needs to be updated:

Discovery Proxy to use within this subnet for managing connection to discovered hosts

to 

Discovery Capsule to use within this subnet for managing connection to discovered hosts

Comment 4 Shimon Shtein 2016-04-07 14:18:12 UTC
Discovery plugin does not have valid locale/en folder. Once it is added, I will be able to run branding script on it.

Comment 5 Lukas Zapletal 2016-04-12 10:30:02 UTC
Do you need it upstream Shimon? Can't you add one only for downstream?

Since Foreman core does have it, I will add it.

Comment 7 Bryan Kearney 2016-04-12 12:03:03 UTC
Upstream bug assigned to lzap@redhat.com

Comment 8 Bryan Kearney 2016-04-12 12:03:05 UTC
Upstream bug component is Discovery Plugin

Comment 9 Bryan Kearney 2016-04-12 14:03:08 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14589 has been closed
-------------
Anonymous
Applied in changeset commit:foreman_discovery|9ba5afb4536e62e15240fb3a8c25317f6b59cc6a.

Comment 10 Roman Plevka 2016-04-18 13:08:38 UTC
FAILEDQA
the fix didn't seem to land in Snap 8.2 yet.
The label still says "DNS Proxy". Perhaps this needs to be taken care of in branding?

Comment 11 Lukas Zapletal 2016-04-18 14:09:12 UTC
Yeah, I only enabled i18n to make the change. Shimon, switching over to you, you know the process I guess.

Comment 12 Bryan Kearney 2016-04-18 16:03:11 UTC
Upstream bug assigned to lzap@redhat.com

Comment 15 Roman Plevka 2016-05-16 09:08:20 UTC
VERIFIED:

on sat6.2.0 Beta (GA11)

foreman-discovery-image.noarch 1:3.1.1-7.el7sat
rubygem-smart_proxy_discovery.noarch 0:1.0.3-3.el6sat
tfm-rubygem-foreman_discovery.noarch 0:5.0.0.5-1.el6sat
tfm-rubygem-hammer_cli_foreman_discovery.noarch 0:0.0.2.2-1.el6sat

This now displays as 'Discovery Capsule'

Comment 17 errata-xmlrpc 2016-07-27 09:31:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.