Bug 1324666 - stop enable rpcbind.socket with every update
Summary: stop enable rpcbind.socket with every update
Keywords:
Status: CLOSED DUPLICATE of bug 1393721
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-06 22:25 UTC by Harald Reindl
Modified: 2016-11-12 14:40 UTC (History)
2 users (show)

Fixed In Version: rpcbind-0.2.3-11.rc1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-12 14:40:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Harald Reindl 2016-04-06 22:25:02 UTC
i am tired having to disable the socket with each and every update since "rpcbind" itself is only used *if* i start the NFS service for VMware backups with "nfs-start.sh"

[root@srv-rhsoft:~]$ systemctl disable rpcbind.socket; systemctl stop rpcbind.socket
Removed symlink /etc/systemd/system/sockets.target.wants/rpcbind.socket.

Apr 07 00:22:06 INFO Upgraded: rpcbind-0.2.3-7.rc1.fc23.x86_64

Apr  7 00:22:05 srv-rhsoft systemd: Listening on RPCbind Server Activation Socket.
Apr  7 00:22:05 srv-rhsoft systemd: Starting RPCbind Server Activation Socket.
Apr  7 00:22:06 srv-rhsoft systemd: Stopping RPCbind Server Activation Socket.
Apr  7 00:22:06 srv-rhsoft systemd: Listening on RPCbind Server Activation Socket.
Apr  7 00:22:06 srv-rhsoft systemd: Starting RPCbind Server Activation Socket.
Apr  7 00:22:07 srv-rhsoft systemd: Stopping RPCbind Server Activation Socket.
Apr  7 00:22:07 srv-rhsoft systemd: Listening on RPCbind Server Activation Socket.
Apr  7 00:22:07 srv-rhsoft systemd: Starting RPCbind Server Activation Socket.

Comment 1 Harald Reindl 2016-08-08 08:49:12 UTC
DAMNED stop it - and no mask them won't work if you just have the packages installed and configured to mount a LUKS encrypted external backup disk and share it over NFS to start virtual servers in case of emergency from there

when i say "systemctl disable" i mean that and *nobody* has a business to fire "systemctl enable" at every random update

Comment 2 Yu Watanabe 2016-08-09 06:53:01 UTC
rpcbind-0.2.3-11.rc1.fc24.x86_64 still enables rpcbind.socket.

Please also remove systemctl-enable commands, or use systemctl-preset command in the trigger scripts. I do not understand why such trigger scripts are necessary in the first place.

====
%triggerun -- rpcbind < 0.2.0-15
%{_bindir}/systemd-sysv-convert --save rpcbind >/dev/null 2>&1 ||:
/bin/systemctl --no-reload enable rpcbind.service >/dev/null 2>&1
/sbin/chkconfig --del rpcbind >/dev/null 2>&1 || :
/bin/systemctl try-restart rpcbind.service >/dev/null 2>&1 || :

%triggerin -- rpcbind > 0.2.2-2.0
/bin/systemctl enable rpcbind.socket  >/dev/null 2>&1 || :
/bin/systemctl restart rpcbind.socket >/dev/null 2>&1 || :

Comment 3 Fedora Update System 2016-08-27 16:20:09 UTC
rpcbind-0.2.3-8.rc1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d4ae4edcbb

Comment 4 Fedora Update System 2016-08-27 16:20:19 UTC
rpcbind-0.2.3-11.rc1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d5ed976bf1

Comment 5 Fedora Update System 2016-08-28 16:19:20 UTC
rpcbind-0.2.3-11.rc1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d5ed976bf1

Comment 6 Fedora Update System 2016-08-28 16:19:42 UTC
rpcbind-0.2.3-8.rc1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d4ae4edcbb

Comment 7 Fedora Update System 2016-09-01 03:19:42 UTC
rpcbind-0.2.3-11.rc1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Harald Reindl 2016-11-10 14:29:19 UTC
today rpcbind.x86_64 0.2.3-11.rc2.fc24 landed in updates-testing and that bullshit still happened - so what is here "Status: ON_QA -> CLOSED"

[root@srv-rhsoft:~]$ systemctl disable rpcbind.socket
Removed symlink /etc/systemd/system/sockets.target.wants/rpcbind.socket

Comment 9 Steve Dickson 2016-11-12 14:40:43 UTC

*** This bug has been marked as a duplicate of bug 1393721 ***


Note You need to log in before you can comment on or make changes to this bug.