Bug 1324672 - AT-SPI2 driver is missing
Summary: AT-SPI2 driver is missing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: brltty   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Jan Ščotka
Lucie Maňásková
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-06 22:53 UTC by Jaroslav Škarvada
Modified: 2016-11-04 01:45 UTC (History)
2 users (show)

Fixed In Version: brltty-4.5-11.el7
Doc Type: Release Note
Doc Text:
AT-SPI2 driver added to *brltty* The Assistive Technology Service Provider Interface driver version 2 (AT-SPI2) has been added to the *brltty* daemon. AT-SPI2 enables using *brltty* with, for example, the GNOME Accessibility Toolkit.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:45:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2259 normal SHIPPED_LIVE brltty bug fix update 2016-11-03 13:32:32 UTC

Description Jaroslav Škarvada 2016-04-06 22:53:39 UTC
Description of problem:
There is an obsoleted AT-SPI driver, but not the recent AT-SPI2 driver which makes usage with e.g. Gnome Accessibility / Orca a bit problematic.

Version-Release number of selected component (if applicable):
brltty-4.5-9.el7

How reproducible:
Always

Steps to Reproduce:
1. brltty -b xw -x a2 -A auth=none
2. tail /var/log/messages

Actual results:
Apr  7 00:50:13 localhost brltty[4709]: cannot load screen driver: /usr/lib64/brltty/libbrlttyxa2.so
Apr  7 00:50:13 localhost brltty[4709]: screen driver not loadable: a2

And erratic behaviour.

Expected results:
No error, normal behaviour.

Additional info:

Comment 9 errata-xmlrpc 2016-11-04 01:45:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2259.html


Note You need to log in before you can comment on or make changes to this bug.