Bug 132469 - seek-to-end issue with neon method
seek-to-end issue with neon method
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-13 16:01 EDT by John (J5) Palmieri
Modified: 2013-04-02 00:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 04:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John (J5) Palmieri 2004-09-13 16:01:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
When trying to view a PDF from a link in a web page in Epiphany, gpdf
launches and then crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to http://people.redhat.com/~hp/stateless/ in a browser
2. Click StatelessLinux.pdf
    

Actual Results:  gpdf launches and a crash dialog apears

Expected Results:  gpdf launches and displays the document

Additional info:

works fine if I download the pdf first and launch it from nautilus.
Comment 1 Dan Williams 2004-09-16 23:13:13 EDT
#0  0x00a79782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cda053 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x06f31f50 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x080d1dc6 in GnomeVFSStream::getChar ()
#5  0x0808ff84 in Stream::getLine ()
#6  0x0809b9f3 in XRef::constructXRef ()
#7  0x0809c389 in XRef::XRef ()
#8  0x0808ed8a in PDFDoc::setup ()
#9  0x0808eea7 in PDFDoc::PDFDoc ()
#10 0x080d822d in gpdf_persist_file_get_pdf_doc ()
#11 0x00a3a077 in _ORBIT_skel_small_Bonobo_PersistFile_load () from
/usr/lib/libbonobo-2.so.0
#12 0x009e1bfd in ORBit_POA_setup_root () from /usr/lib/libORBit-2.so.0
#13 0x009e682f in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0
#14 0x009d2f77 in ORBit_small_invoke_adaptor () from
/usr/lib/libORBit-2.so.0
#15 0x009e2002 in ORBit_POAObject_post_invoke () from
/usr/lib/libORBit-2.so.0
#16 0x009e2682 in ORBit_POAObject_post_invoke () from
/usr/lib/libORBit-2.so.0
#17 0x009e2a9c in ORBit_POAObject_post_invoke () from
/usr/lib/libORBit-2.so.0
#18 0x009e6784 in ORBit_handle_request () from /usr/lib/libORBit-2.so.0
#19 0x009cffb8 in giop_connection_handle_input () from
/usr/lib/libORBit-2.so.0
#20 0x009ecc39 in link_connection_set_max_buffer () from
/usr/lib/libORBit-2.so.0
#21 0x009ee90f in link_servers_move_io_T () from /usr/lib/libORBit-2.so.0
#22 0x00d064fb in g_main_context_dispatch (context=0x8a10f70) at
gmain.c:1942
#23 0x00d07f82 in g_main_context_iterate (context=0x8a10f70, block=1,
dispatch=1, self=0x89f12f8) at gmain.c:2573
#24 0x00d0822f in g_main_loop_run (loop=0x8a50f30) at gmain.c:2777
#25 0x00a25c45 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#26 0x00a23ea3 in bonobo_generic_factory_main_timeout () from
/usr/lib/libbonobo-2.so.0
#27 0x00a23f27 in bonobo_generic_factory_main () from
/usr/lib/libbonobo-2.so.0
#28 0x0807d38b in main ()
Comment 2 Mark McLoughlin 2004-09-17 08:13:43 EDT
Looks like a problem with seeking in the neon gnome-vfs method - I'll
continue debugging later
Comment 3 Mark McLoughlin 2004-09-20 10:46:43 EDT
Yep, seek-to-end problem with the neon method:

  http://bugzilla.gnome.org/show_bug.cgi?id=153153
Comment 4 Mark McLoughlin 2004-09-20 10:47:30 EDT
(Only leaving it open so we can decide whether to backport or not)
Comment 5 Mark McLoughlin 2004-09-20 11:09:49 EDT
gpdf error checking patch at:

  http://bugzilla.gnome.org/show_bug.cgi?id=153159

(No need to backport that I think)
Comment 6 Mark McLoughlin 2004-09-21 04:24:19 EDT
Alex has committed the gnome-vfs patch upstream and is going to do a
release soon - no need to backport. Closing UPSTREAM
Comment 7 Dan Williams 2004-09-22 06:03:10 EDT
I'm going to stuff the patch into gpdf-2.8.0 anyway...

Note You need to log in before you can comment on or make changes to this bug.