Bug 132470 - Feature request: up2date: add, update-all & remove - combined
Feature request: up2date: add, update-all & remove - combined
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 16:03 EDT by William R. Somsky
Modified: 2010-04-09 04:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-09 04:08:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William R. Somsky 2004-09-13 16:03:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
This feature request involves two existings up2date operations:
adding new packages and updating all currently installed packages,
and one new feature: removing currently installed packages.
(Cf. Bugzilla ID 103694 for an existing suggestion to add package
removal.)

With the current up2date, one can install new packages or update
all installed packages, and there is a suggestion to add the option
of being able to remove installed packages.  However, with adding 
and updating-all -- and presumably removing if that is added -- only 
one of these types of operations may be done in a single up2date
invocation.

Frequently, however, in bringing a system into a desired
installation state, one will want/need to have some packages
added, some deleted, and everything left updated to the currently
available version.  Having to perform these as separate invocations
to up2date is inefficient: both in terms of administrator actions
and access to the RHN.  Furthermore, in the cases of swapping 
out one package that provides a service required by some other 
currently installed packages with an alternate package providing
the same service (eg, sendmail vs postfix, or something similar)
this cannot be done as separate operations without disregarding 
package dependancy requirements.

It would be highly useful therefore to be able to specify packages
to be added, and removed, and that a global update be performed in a
single up2date invocation that will do all the requested operations
as a single rpm transaction.

Furthermore, it would be even more useful to be able to specify 
(possibly in a command-line specified file, or part of the up2date
configuration) a list of packages that should be currently installed
and ones that should be currently _not_ installed (all unmentioned
files left in their current installed/uninstalled state), and have
up2date install or remove packages as needed (and update everything
if also requested), but remain silent if nothing need be done; ie.
no "already updated" or "is not installed" messages.  An "I want
exactly these packages" mode might be useful also, but one which
leaves unspecified packages "as-is" is more useful for my cases.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. attempt to run up2date to add, update and remove packages
   in a single operation
2. it can not currently be done...

(Hey, the form required something here...)

Additional info:
Comment 2 Miroslav Suchý 2010-04-09 04:08:45 EDT
Since up2date is obsoleted by yum in Red Hat Enterprise Linux 5. We will not such big feature into up2date.
If you are still looking for such feature, please create new bugzilla against yum component.

Note You need to log in before you can comment on or make changes to this bug.