Bug 1324766 - Installer create upstream openscap repo file by default
Summary: Installer create upstream openscap repo file by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 08:57 UTC by Marek Hulan
Modified: 2019-09-26 14:36 UTC (History)
6 users (show)

Fixed In Version: foreman-installer-1.11.0.2-1,foreman-installer-1.11.0.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:08:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14520 None None None 2016-04-22 16:46:27 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Marek Hulan 2016-04-07 08:57:09 UTC
Description of problem:

When I run

    foreman-installer --enable-foreman-plugin-openscap

it automatically adds upstream isimluk-openscap repo.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. foreman-installer --enable-foreman-plugin-openscap
2. ls /etc/yum.repos.d/isimluk-openscap.repo

Actual results:

File is present

Expected results:

File is not present

Additional info:

Easy workaround is to call 

    foreman-installer --enable-foreman-plugin-openscap --foreman-plugin-openscap-configure-openscap-repo false

Comment 1 Marek Hulan 2016-04-07 09:08:43 UTC
Created redmine issue http://projects.theforeman.org/issues/14520 from this bug

Comment 3 Bryan Kearney 2016-04-07 10:05:58 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 4 Bryan Kearney 2016-04-07 10:06:00 UTC
Upstream bug component is Installer

Comment 5 Bryan Kearney 2016-04-07 10:06:01 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 6 Bryan Kearney 2016-04-08 10:06:00 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14520 has been closed
-------------
Marek Hulán
Applied in changeset commit:puppet-foreman|361136edfec01f2cba9b1d00c927133e952c7ed9.

Comment 7 Roman Plevka 2016-04-19 09:32:30 UTC
Failed QA.
Sat 6.2.0 Snap 8.2

the repo is still being created and endabled:

# foreman-installer --enable-foreman-plugin-openscap --scenario katello
...
# ll | grep isimluk
-rw-r--r--. 1 root root   130 Apr 19 04:58 isimluk-openscap.repo


# grep openscap_repo foreman-installer/scenarios.d/katello-answers.yaml
    configure_openscap_repo: true

Not sure whether the fix made it to the Snap

Comment 9 Kedar Bidarkar 2016-04-21 11:24:28 UTC
Let me work on this bug as the installer options are very confusing and I need to raise couple of bugs related to it.

Comment 10 Kedar Bidarkar 2016-04-21 12:20:16 UTC
VERIFIED with sat62-snap9.0

This issue is no longer seen and no such repo isimluk-openscap.repo is now created in /etc/yum.repos.d/

Comment 13 Marek Hulan 2016-05-20 11:43:21 UTC
I verified this works as expected with GA snap 12.1, code is in place now, moving to ON_QA to double-check.

Comment 14 Ondřej Pražák 2016-05-27 11:46:50 UTC
satellite-installer --enable-foreman-plugin-openscap
ls /etc/yum.repos.d/ | grep isimluk

The file is not present, verified with snap 13.1

Comment 16 errata-xmlrpc 2016-07-27 09:08:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.