Bug 1324842 - The readonly_user_name generated in ceilometer.conf post undercloud upgrade is too long
Summary: The readonly_user_name generated in ceilometer.conf post undercloud upgrade i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 12:33 UTC by Marius Cornea
Modified: 2016-12-14 15:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the director auto-generated a value for 'readonly_user_name' (in /etc/ceilometer/ceilometer.conf) that exceeded the 32-characters. This resulted in ValueSizeConstraint errors during upgrades. With this release, the director now sets 'readonly_user_name' to 'ro_snmp_user' by default, which ensures compliance with the character limit.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:31:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Marius Cornea 2016-04-07 12:33:35 UTC
Description of problem:
The readonly_user_name generated in ceilometer.conf post undercloud upgrade is too long 

Version-Release number of selected component (if applicable):
instack-0.0.8-2.el7ost.noarch
instack-undercloud-2.2.7-2.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy 7.3 undercloud
2. Upgrade to 8 

Actual results:
root@instack:/home/stack# grep readonly_user_name /etc/ceilometer/ceilometer.conf
readonly_user_name=6dd2a919d43c1d29d5e6e4751f0747c1003f8e9b

/var/log/ceilometer/central.log shows the following error:
2016-04-07 08:28:39.980 28543 ERROR ceilometer.hardware.pollsters.generic ValueConstraintError: ConstraintsIntersection(ConstraintsIntersection(ConstraintsIntersection(ConstraintsIntersection(), ValueSizeConstraint(0, 65535)), ValueSizeConstraint(0, 255)), ValueSizeConstraint(1, 32)) failed at: "ValueSizeConstraint(1, 32) failed at: "6dd2a919d43c1d29d5e6e4751f0747c1003f8e9b"" at SnmpAdminString


Expected results:
The generated snmp user is within 32 characters limit.

Comment 2 Mike Burns 2016-04-07 21:36:02 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 7 errata-xmlrpc 2016-12-14 15:31:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.