Bug 1324861 (league/plates) - Review Request: php-league-plates - Native PHP template system
Summary: Review Request: php-league-plates - Native PHP template system
Status: CLOSED ERRATA
Alias: league/plates
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: James Hogarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 13:08 UTC by Remi Collet
Modified: 2016-04-26 23:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-12 09:38:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
james.hogarth: fedora-review+


Attachments (Terms of Use)

Description Remi Collet 2016-04-07 13:08:10 UTC
Spec URL: https://raw.githubusercontent.com/remicollet/remirepo/d177323ba2dde983772a56f28b19da3df41d73d0/php/php-league-plates/php-league-plates.spec
SRPM URL: http://rpms.remirepo.net/SRPMS/php-league-plates-3.1.1-1.remi.src.rpm
Description: 
Plates is a native PHP template system that's fast, easy to use and easy
to extend. It's inspired by the excellent Twig template engine and strives
to bring modern template language functionality to native PHP templates.
Plates is designed for developers who prefer to use native PHP templates
over compiled template languages, such as Twig or Smarty.



Fedora Account System Username: remi

Comment 1 Remi Collet 2016-04-07 13:09:13 UTC
Owncloud 9.0 new dependency (from owncloud/updater/composer.json)

Comment 2 James Hogarth 2016-04-07 14:27:08 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed

===== Issues =====

 * Package does not own files or directories owned by other packages.
   - OKAY : Common php vendor so shares vendor path since no parent BR owning
 * Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT)
   - EPEL5 boilerplate to be removed
 * Each %files section contains %defattr if rpm < 4.4
   - EPEL5 boilerplate to be removed
 * Buildroot is not present
   - EPEL5 boilerplate to be removed
 * Package has no %clean section with rm -rf %{buildroot} (or
   - EPEL5 boilerplate to be removed
 * RPMlint: strange-permission makesrc.sh 775
   - Used to pack with tests, not included in rpm
 * SourceX is a working URL.
   - Source is a repack of commit to include tests excluded from release. 
   - Verified included source matches the commit from repo

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "MIT/X11 (BSD like)", "Unknown or generated". 28 files have
     unknown license. Detailed output of licensecheck in
     /home/james/workspace/fedora-scm/1324861-php-league-
     plates/licensecheck.txt
[!]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/share/php/League(php-
     league-flysystem)
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[x]: Sources contain only permissible code or content.
[!]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 3 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[!]: Buildroot is not present
     Note: Buildroot: present but not needed
[!]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: %clean present but not required
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Reviewer should test that the package builds in mock.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[!]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.

PHP:
[x]: Run phpci static analyze on all php files.
     Note: phpCompatInfo version 5.0.0 DB built Mar 07 2016 07:28:32 CET
     static analyze results in /home/james/workspace/fedora-scm/1324861
     -php-league-plates/phpci.log


Rpmlint
-------
Checking: php-league-plates-3.1.1-1.fc25.noarch.rpm
          php-league-plates-3.1.1-1.fc25.src.rpm
php-league-plates.noarch: W: spelling-error %description -l en_US Autoloader -> Auto loader, Auto-loader, Freeloader
php-league-plates.noarch: W: spelling-error %description -l en_US autoload -> auto load, auto-load, tautology
php-league-plates.src: W: spelling-error %description -l en_US Autoloader -> Auto loader, Auto-loader, Freeloader
php-league-plates.src: W: spelling-error %description -l en_US usr -> use, us, user
php-league-plates.src: W: spelling-error %description -l en_US autoload -> auto load, auto-load, tautology
php-league-plates.src: W: strange-permission makesrc.sh 775
php-league-plates.src: W: invalid-url Source0: php-league-plates-3.1.1-2d8569e.tgz
2 packages and 0 specfiles checked; 0 errors, 7 warnings.




Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
php-league-plates.noarch: W: spelling-error %description -l en_US Autoloader -> Auto loader, Auto-loader, Freeloader
php-league-plates.noarch: W: spelling-error %description -l en_US autoload -> auto load, auto-load, tautology
1 packages and 0 specfiles checked; 0 errors, 2 warnings.



Requires
--------
php-league-plates (rpmlib, GLIBC filtered):
    php-composer(symfony/class-loader)
    php-pcre
    php-spl



Provides
--------
php-league-plates:
    php-composer(league/plates)
    php-league-plates



Generated by fedora-review 0.6.0 (3c5c9d7) last change: 2015-05-20
Command line :/usr/bin/fedora-review -b 1324861 -m fedora-rawhide-x86_64
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, PHP, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

===== Result =====
APPROVED (with the EPEL5 boilerplate removed after import)

As a side note some of the boilerplate (eg the clean and buildroot) are no longer required for EPEL5 as 
a result of the new epel-rpm-macros updates but guidelines have not been altered.

Comment 3 Remi Collet 2016-04-07 14:33:22 UTC
Thanks.
SCM request open on pkgdb2

Comment 4 Fedora Update System 2016-04-07 15:41:22 UTC
php-league-plates-3.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-054d89272d

Comment 5 Fedora Update System 2016-04-07 15:41:28 UTC
php-league-plates-3.1.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-46cd878f05

Comment 6 Fedora Update System 2016-04-07 15:41:33 UTC
php-league-plates-3.1.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4da62a78c2

Comment 7 Fedora Update System 2016-04-07 15:41:37 UTC
php-league-plates-3.1.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f6645b1abf

Comment 8 Fedora Update System 2016-04-08 16:52:52 UTC
php-league-plates-3.1.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-46cd878f05

Comment 9 Fedora Update System 2016-04-08 20:51:02 UTC
php-league-plates-3.1.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-054d89272d

Comment 10 Fedora Update System 2016-04-08 20:54:06 UTC
php-league-plates-3.1.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4da62a78c2

Comment 11 Fedora Update System 2016-04-08 21:49:47 UTC
php-league-plates-3.1.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f6645b1abf

Comment 12 Fedora Update System 2016-04-12 09:38:46 UTC
php-league-plates-3.1.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-04-18 03:20:45 UTC
php-league-plates-3.1.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-04-18 03:49:37 UTC
php-league-plates-3.1.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-04-26 23:54:55 UTC
php-league-plates-3.1.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.