Bug 132488 - PHP causes Apache to crash on subsequent HUP & USR1 signals
PHP causes Apache to crash on subsequent HUP & USR1 signals
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: php (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 19:38 EDT by Oliver Jones
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace log of running process as it receives HUP signals. (307.37 KB, text/plain)
2004-09-13 19:44 EDT, Oliver Jones
no flags Details

  None (edit)
Description Oliver Jones 2004-09-13 19:38:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
With PHP installed Apache crashes when given HUP or USR1 signals.  It
usually doesn't crash on the 1st signal given but on the 2nd or 3rd.  

So every few days the httpd process dies due to receving a HUP signal
from logrotate.



Version-Release number of selected component (if applicable):
php-4.1.2-2.1.8

How reproducible:
Always

Steps to Reproduce:
1. up2date php
2. service httpd restart
3. kill -HUP `cat /var/run/httpd.pid`
4. sleep 2
5. kill -HUP `cat /var/run/httpd.pid`
4. sleep 2
5. kill -HUP `cat /var/run/httpd.pid`

   

Actual Results:  httpd dies with a SEGV.

Expected Results:  That the process continues to run without fault.

Additional info:

I notice some other bugs have been posted in relation to PHP and
Apache crashing on similar problems.  Eg, bug #104419, bug #129567. 
These bugs may all be related in some way.
Comment 1 Oliver Jones 2004-09-13 19:44:08 EDT
Created attachment 103808 [details]
strace log of running process as it receives HUP signals.

This is a strace log of the parent httpd process as it receives multiple HUP
signals.
Comment 2 Joe Orton 2004-09-14 04:24:49 EDT
Thanks for the report.  Can you also try and get a core dump and a
backtrace?  (add "CoreDumpDirectory /tmp" to httpd.conf, and start the
server with "ulimit -c unlimited; apachectl start")

mod_perl was implicated by the backtrace from #129567.
Comment 3 RHEL Product and Program Management 2007-10-19 15:21:31 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.