Bug 1324895 - Unable to establish DSL connection
Summary: Unable to establish DSL connection
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Beniamino Galvani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 14:10 UTC by Sergey Patsynyak
Modified: 2016-04-19 13:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-19 13:24:52 UTC


Attachments (Terms of Use)
NetworkManager.service (155.02 KB, text/x-vhdl)
2016-04-07 14:10 UTC, Sergey Patsynyak
no flags Details
[PATCH] ppp-manager: don't modify the applied connection (1.38 KB, patch)
2016-04-07 21:44 UTC, Beniamino Galvani
no flags Details | Diff

Description Sergey Patsynyak 2016-04-07 14:10:39 UTC
Created attachment 1144754 [details]
NetworkManager.service

Description of problem:

I can't connect to the Internet via DSL connection. I already experienced this on Debian 8.3 though I can't say if the problems are identical. First, I installed Fedora 24 alpha 7 with network manager beta 2. Today I updated network manager to rc1 by tethering with an android phone and I'm still getting the same result. With journalctl -u NetworkManager.service I see these red errors:

Unable to obtain CHAP password for Lnn-201-21 on ASR-FireFly-ID18 from plugin
CHAP authentication failed

<error> [1459779399.746784] [platform/nm-linux-platform.c:3906]   do_change_link():          platform-linux: do-change-link[5]: failure changing link: f

Unable to obtain CHAP password for Lnn-201-21 on ASR-Tylor from plugin

CHAP authentication failed

I attached the full log

Comment 1 Beniamino Galvani 2016-04-07 17:13:08 UTC
I can reproduce this with NM 1.2-rc1 by adding a new DSL connection from nm-connection-editor and trying to activate it. The cause seems to be:

nm-pppd-plugin-Message: nm-ppp-plugin: (get_credentials): passwd-hook, requesting credentials...
nm-pppd-plugin-WARNING **: nm-ppp-plugin: (get_credentials): could not get secrets: GDBus.Error:org.freedesktop.NetworkManager.Settings.Failed: The connection was modified since activation

Comment 2 Beniamino Galvani 2016-04-07 21:44:03 UTC
Created attachment 1144902 [details]
[PATCH] ppp-manager: don't modify the applied connection

The patch fixes the problem for me.

Comment 3 Thomas Haller 2016-04-08 09:18:34 UTC
lgtm

Comment 5 Sergey Patsynyak 2016-04-19 13:24:52 UTC
Beniamino, this works for me as well. Thanks!


Note You need to log in before you can comment on or make changes to this bug.