Bug 13249 - post install configuration hangs on specified but disconnected network
post install configuration hangs on specified but disconnected network
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-30 00:56 EDT by Nitin Dahyabhai
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-13 12:44:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nitin Dahyabhai 2000-06-30 00:56:10 EDT
I went through a CD install on an IBM machine with
an ISA token ring card.  I added the driver in expert
mode and filled in the settings for IP, hostname,
gateway, and primary DNS and told it to activate on
boot.  After all the packages were finished installing,
the message box stuck with the following Python stack
trace (at least, I think it was hung since it had run
through previous installs without network card/driver/
settings with 6.2-like time):


Exception in thread Thread-1:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap
    self.run()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 16, in run
    rc = self.todo.doInstall ()
  File "/usr/lib/anaconda/todo.py", line 1472, in doInstall
    self.writeConfiguration ()
  File "/usr/lib/anaconda/todo.py", line 1235, in writeConfiguration
    self.writeNetworkConfig ()
  File "/usr/lib/anaconda/todo.py", line 585, in writeNetworkConfig
    ip = self.network.lookupHostname()
  File "/usr/lib/anaconda/todo.py", line 150, in lookupHostname
    self.gateway)
  File "/usr/lib/anaconda/isys.py", line 295, in configNetDevice
    return _isys.confignetdevice(device, ip, netmaks, gw)
SystemError: (11, 'Resource temporarily unavailable')
Comment 1 Matt Wilson 2000-07-13 12:44:09 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.