Bug 132490 - i810 video driver flat out reboots the entire sytem
i810 video driver flat out reboots the entire sytem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 21:28 EDT by Joshua Ginsberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 06:24:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Ginsberg 2004-09-13 21:28:43 EDT
I've been trying to configure a multiheaded setup for my new
workstation which has an onboard AGP i810 video controller and a PCI
Voodoo3 video controller. When I configured it in Multihead mode, when
X starts, the entire machine reboots. I tried configuring it for
singlehead using only the i810, and when X starts, the entire machine
reboots. I tried configuring it for singlehead using on the tdfx, and
when X starts, all is well.

The /var/log/Xorg.0.log file gives no information of any help. Running
Xorg -probeonly does not yield any error that would shed light on the
problem. I don't know what other debugging steps I can try.

I've tried upgrading to the latest Rawhide version of the server
(6.7.99.903-6) and the problem remains.

Please help! I need multiheaded for my work!

-jag
Comment 1 Joshua Ginsberg 2004-09-13 21:52:49 EDT
Okay, update.

Now the i810 doesn't crash the entire system -- it just blanks the 
screen with a white square as my mouse cursor, locks up the keyboard, 
crashes X, and won't give me control of my video anymore.

However, once I physically remove the tdfx hardware, all is well with 
the i810. It works just great.

Is it a memory conflict of some sort?

-jag
Comment 2 Mike A. Harris 2004-09-13 23:33:27 EDT
If 3Dfx video hardware is used in a multihead system, it must
be configured to be the "Primary" VGA device.  You need to go into
your BIOS CMOS settings and set the onboard video to be non-primary.

This is either a complex long standing bug in the tdfx driver, or
it is a 3Dfx BIOS bug.  Nobody has ever debugged the issue that
deep to draw any conclusions however.

Let us know if setting the 3Dfx to be the primary VGA device
works.

TIA
Comment 3 Joshua Ginsberg 2004-09-14 03:21:45 EDT
In the examination of the problem above, the 3dfx acts as the primary
graphics adaptor. There is a BIOS setting for selecting PCI vs. AGP as
the primary, but it seems to have no affect. Console always appears on
the 3dfx card and /etc/X11/xorg.conf treats the tdfx device as the
primary device. The i810 device has BusID but tdfx device does not.

-jag
Comment 5 Mike A. Harris 2005-02-01 06:24:52 EST
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.