Bug 1324984 - AttributeError: '_ResultTuple' object has no attribute 'get_tags'
Summary: AttributeError: '_ResultTuple' object has no attribute 'get_tags'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 18:46 UTC by Peter Trenholme
Modified: 2016-05-16 16:22 UTC (History)
1 user (show)

Fixed In Version: yumex-dnf-4.3.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-16 16:22:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Trenholme 2016-04-07 18:46:44 UTC
Description of problem:AttributeError: '_ResultTuple' object has no attribute 'get_tags'

Version-Release number of selected component (if applicable): 4.1.4-1.fc24

How reproducible: Didn't try

Steps to Reproduce: $ yumex-dnf &

Actual results:
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/yumex/gui/widgets.py", line 455, in on_mouse_motion
    tags = widget.get_iter_at_location(x, y).get_tags()
AttributeError: '_ResultTuple' object has no attribute 'get_tags'
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/yumex/gui/widgets.py", line 455, in on_mouse_motion
    tags = widget.get_iter_at_location(x, y).get_tags()
AttributeError: '_ResultTuple' object has no attribute 'get_tags'
...

Expected results:
11:31:23: Saving config on exit

Additional info:
Note that the error messages are, of course, not displayed when the app is started from a .desktop file.

Comment 1 Tim Lauridsen 2016-04-28 10:36:58 UTC
Caused by some changes in Gtk

Upstream issue:

https://github.com/timlau/yumex-dnf/issues/94

Fixed upstream in dev version

Comment 2 Fedora Update System 2016-05-11 09:02:44 UTC
dnfdaemon-0.3.15-1.fc24 yumex-dnf-4.3.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4

Comment 3 Fedora Update System 2016-05-12 09:41:40 UTC
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa868f02e4

Comment 4 Fedora Update System 2016-05-16 16:22:29 UTC
dnfdaemon-0.3.15-1.fc24, yumex-dnf-4.3.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.