Bug 1325069 - Don't hide latest Image Stream on management console
Summary: Don't hide latest Image Stream on management console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-08 06:56 UTC by Kenjiro Nakayama
Modified: 2019-10-10 11:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The builder images in the web console were not ordered by semantic version. Consequence: In some cases, a newer technology version could be hidden under a "See All" link because it had a lower sort order. Fix: The builders are now properly ordered by their semantic version. Result: More recent version will be sorted to the top and not be hidden.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:37:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot when I access to the console first (101.45 KB, image/png)
2016-04-08 06:56 UTC, Kenjiro Nakayama
no flags Details
screenshot after I pushed "See all" (112.31 KB, image/png)
2016-04-08 06:57 UTC, Kenjiro Nakayama
no flags Details
FirstLoad (44.79 KB, image/png)
2016-08-04 05:48 UTC, Yadan Pei
no flags Details
ClickedSeeAll (49.96 KB, image/png)
2016-08-04 05:48 UTC, Yadan Pei
no flags Details
PythonWithLatestWord (39.94 KB, image/png)
2016-08-12 03:31 UTC, Yadan Pei
no flags Details
JbossEAP64BeforeSeeAll (57.81 KB, image/png)
2016-08-12 03:34 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Kenjiro Nakayama 2016-04-08 06:56:42 UTC
Created attachment 1145026 [details]
screenshot when I access to the console first

Description of problem:

- On screen "Select Image or Template", latest stream version is hidden.

Version-Release number of selected component (if applicable):

- OSE v3.1.1.6 (xpaas 1.2)

How reproducible:

Steps to Reproduce:
1. Go webconsole
2. Push Add to project
3. You can see "jboss-eap64-openshift:1.1", but you can NOT see "jboss-eap64-openshift:1.2" by default
NOTE: if you use "See all", you can see 1.2 as well.

Actual results:

- Most of the user select "jboss-eap64-openshift:1.1" due to the hidden 1.2 stream.

Expected results:

- show latest image (in this case "jboss-eap64-openshift:1.2"), and hide previous versions by default.

Additional info:

- Attached screen shot.
  - jboss-eap64-11.png is the screenshot when I access to the console first.
  - after-see-all.png is the screen shot after I pushed "See all".

Comment 1 Kenjiro Nakayama 2016-04-08 06:57:16 UTC
Created attachment 1145027 [details]
screenshot after I pushed "See all"

Comment 2 Jessica Forrester 2016-04-08 12:42:35 UTC
We need the change from the API that's been discussed where the API will return tags ordered by semantic version.

Comment 3 Paul Weil 2016-04-08 12:48:25 UTC
TODO for PM side:  Update the image stream api to return tags ordered by semantic version.

Comment 4 Maciej Szulik 2016-06-28 15:08:29 UTC
I've changed how tags in status are sorted, I hope that will suffice. See https://github.com/openshift/origin/pull/9606

Comment 5 openshift-github-bot 2016-08-02 19:51:57 UTC
Commits pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/8e83ad04ae59e7e8d25bb7c40ea606639c5d8f8e
Bug 1325069 - Sort status tags according to semver

https://github.com/openshift/origin/commit/5172a56a2188d00446bad94ea92981d4f0737c29
Merge pull request #9606 from soltysh/bug1325069

Merged by openshift-bot

Comment 6 Yadan Pei 2016-08-04 05:46:42 UTC
Check against v3.3.0.14


Now installed image stream jboss-eap64-openshift has four tags:1.1,1.2,1.3 and 1.4

After initial load, jboss-eap64-openshift:1.1 jboss-eap64-openshift:1.2 jboss-eap64-openshift:1.3 will be shown in list, latest jboss-eap64-openshift:1.4 is not shown until click "See all"

Seems latest image stream is still hidden

Comment 7 Yadan Pei 2016-08-04 05:48:16 UTC
Created attachment 1187359 [details]
FirstLoad

Comment 8 Yadan Pei 2016-08-04 05:48:54 UTC
Created attachment 1187360 [details]
ClickedSeeAll

Comment 9 Maciej Szulik 2016-08-05 10:13:27 UTC
Jessica which information you're looking at spec or status? I've currently fixed status which returns tags in aforementioned semantic version order like so (cut the output for brevity):

$ oc get is/python -n openshift -o yaml
apiVersion: v1
kind: ImageStream
metadata:
  name: python
  namespace: openshift
spec:
  tags:
  - name: "2.7"
  - name: "3.3"
  - name: "3.4"
  - name: "3.5"
  - name: latest
status:
  dockerImageRepository: 172.30.105.175:5000/openshift/python
  tags:
  - tag: latest
  - tag: "3.5"
  - tag: "3.4"
  - tag: "3.3"
  - tag: "2.7"

Comment 10 Jessica Forrester 2016-08-05 13:14:37 UTC
We use status, I suspect we are messing up the sort order somewhere in the console code, I'll reassign this and we will take a look.

Comment 11 Maciej Szulik 2016-08-05 14:07:41 UTC
Thanks!

Comment 13 Jessica Forrester 2016-08-05 20:39:21 UTC
merging to origin in https://github.com/openshift/origin/pull/10253

Comment 14 Jessica Forrester 2016-08-05 20:42:08 UTC
sorry forgot this was an OCP bug, leaving as assigned to origin PR merges

Comment 15 Yadan Pei 2016-08-12 03:25:58 UTC
Checked against v3.3.0.18,


For xpaas images, it didn't show which image is latest

Take jboss-eap64-openshift as example

# oc get is/jboss-eap64-openshift -n openshift -o yaml

status:
  tags:
    tag: latest
    tag: "1.4"
    tag: "1.3"
    tag: "1.2"
    tag: "1.1"

jboss-eap64-openshift:1.4 is the latest image, this should be identified on web console

Comment 16 Yadan Pei 2016-08-12 03:31:16 UTC
Created attachment 1190255 [details]
PythonWithLatestWord

Comment 17 Yadan Pei 2016-08-12 03:34:11 UTC
Attachment  PythonWithLatestWord shows Python:3.5 is latest image

Comment 18 Yadan Pei 2016-08-12 03:34:58 UTC
Created attachment 1190256 [details]
JbossEAP64BeforeSeeAll

Comment 19 Yadan Pei 2016-08-12 03:36:13 UTC
In attachment JbossEAP64BeforeSeeAll, jboss-eap64-openshift:1.4 was not indicated as latest image where should be

Comment 20 Samuel Padgett 2016-08-12 12:52:28 UTC
The JBoss image streams have no :latest tag. The console will only show latest for image streams that have a :latest tag which references another tag in the same stream.

Comment 21 Samuel Padgett 2016-08-12 13:15:16 UTC
(In reply to Samuel Padgett from comment #20)
> The JBoss image streams have no :latest tag. The console will only show
> latest for image streams that have a :latest tag which references another
> tag in the same stream.

Sorry please disregard. I was looking at the wrong image stream.

Comment 22 Samuel Padgett 2016-08-12 17:55:24 UTC
OK, I believe I see the problem. There is a status tag latest, but no spec tag latest. Since the `from` definition is on the spec tag, we can't mark 1.4 latest in the web console. See

https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_examples/files/examples/v1.3/xpaas-streams/jboss-image-streams.json#L83-L146

Here's an example of an image stream with a latest spec tag.

https://github.com/openshift/origin/blob/master/examples/image-streams/image-streams-centos7.json#L14-L27

Even if we look at status tags, there is no way we can know what :latest tracks without the spec. So the web console is behaving as I'd expect, and the image stream needs to be updated if we want that behavior for the JBoss builder images.

Comment 23 Yadan Pei 2016-08-15 06:32:50 UTC
Samuel, thanks for your explanation, I got what you mean.

Comment 25 errata-xmlrpc 2016-09-27 09:37:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.