Bug 1325114 - FTBFS: DMRTest: 73 74 75 76 77 78 79 80 81 82 83 84 failed
Summary: FTBFS: DMRTest: 73 74 75 76 77 78 79 80 81 82 83 84 failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libdap
Version: 24
Hardware: ppc64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-04-08 09:45 UTC by Karsten Hopp
Modified: 2016-05-07 12:06 UTC (History)
3 users (show)

Fixed In Version: libdap-3.17.2-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-07 12:06:38 UTC


Attachments (Terms of Use)
build.log (283.57 KB, text/plain)
2016-04-08 09:45 UTC, Karsten Hopp
no flags Details
DMRtest directory and log (80.25 KB, application/octet-stream)
2016-04-08 09:51 UTC, Karsten Hopp
no flags Details
attach a patch to disable dmr test on big endian machines (2.40 KB, patch)
2016-04-13 17:28 UTC, Ngo Than
no flags Details | Diff

Description Karsten Hopp 2016-04-08 09:45:39 UTC
Created attachment 1145076 [details]
build.log

Description of problem:
 72: parse dmr-testsuite/test_simple_6.3.xml         ok
 73: trans test_array_9.xml                          FAILED (DMRTest.at:247)
 74: trans test_array_12.xml                         FAILED (DMRTest.at:247)
 75: trans test_array_13.xml                         FAILED (DMRTest.at:247)
 76: trans test_array_14.xml                         FAILED (DMRTest.at:247)
 77: trans test_simple_6.2.xml                       FAILED (DMRTest.at:247)
 78: trans test_simple_6.3.xml                       FAILED (DMRTest.at:247)
 79: intern test_array_9.xml                         FAILED (DMRTest.at:247)
 80: intern test_array_12.xml                        FAILED (DMRTest.at:247)
 81: intern test_array_13.xml                        FAILED (DMRTest.at:247)
 82: intern test_array_14.xml                        FAILED (DMRTest.at:247)
 83: intern test_simple_6.2.xml                      FAILED (DMRTest.at:247)
 84: intern test_simple_6.3.xml                      FAILED (DMRTest.at:247)
 85: trans ce test_array_4.xml a test_array_4.xml.1.trans_base ok
...
## ------------- ##
## Test results. ##
## ------------- ##
ERROR: All 188 tests were run,
16 failed (4 expected failures).
## ------------------------ ##
## DMRTest.log was created. ##
## ------------------------ ##
Please send `tests/DMRTest.log' and all information you think might help:
   To: <opendap-tech@opendap.org>
   Subject: [libdap 3.17.0] DMRTest: 73 74 75 76 77 78 79 80 81 82 83 84 failed
You may investigate any problem if you feel able to do so, in which
case the test suite provides a good starting point.  Its output may
be found below `tests/DMRTest.dir'.

Version-Release number of selected component (if applicable):
libdap-3.17.0-1.fc24

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f24 libdap-3.17.0-1.fc24.src.rpm
2.
3.

Actual results:


Expected results:


Additional info:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3283128

Comment 1 Karsten Hopp 2016-04-08 09:51:40 UTC
Created attachment 1145078 [details]
DMRtest directory and log

Comment 2 Dan Horák 2016-04-08 10:28:50 UTC
This should be already known to upstream and if I understood correctly, he needs to re-generate the output files on a big endian machine (he has access to the openpower hub guest).

With an update to 3.17.1 we will get s390(x) support, because the endian detection was fixed, so I would suggest to disable/remove the known failing tests for the next Fedora builds until fixed in upstream. Broken libdap build is currently blocking the whole GIS stack for Power and s390(x).

Comment 3 Ngo Than 2016-04-13 17:28:21 UTC
Created attachment 1146919 [details]
attach a patch to disable dmr test on big endian machines

ATM it's just a workaround before the upstream adds the missing files for big endian in the future.

Comment 4 Ngo Than 2016-04-13 17:33:35 UTC
libdap just built fine with the workaround. In my opinion we should build it with this workaround before upstream provides correct fix. As Dan mentioned the broken libdap build is currently blocking the whole GIS stack for Power and s390(x).

We know these DRM tests only works on little endian.

http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2183435
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3298724
http://koji.fedoraproject.org/koji/taskinfo?taskID=13647915

Comment 5 Orion Poplawski 2016-04-13 17:42:35 UTC
Looks good to me.  I believe you are a proven packager so feel free to commit.

Comment 6 Dan Horák 2016-04-13 17:52:27 UTC
looking at the patch, it seems the tests should be already disabled for non-little-endians, maybe worth investigating the root cause a bit

Also 3.17.1 should be required for s390(x) to correctly detect the endianess - fixed in https://github.com/OPENDAP/libdap4/commit/5b9bc3533bdef37aac938e801d3140dbceb1fe8b

Comment 7 Dan Horák 2016-04-13 17:54:21 UTC
hm, maybe it's $ac_word_order vs. $WORD_ORDER in the tests/DMRTest.at

Comment 8 Ngo Than 2016-04-14 13:01:13 UTC
Orion ,there's a new 3.17.1 release which fixes big endian issues. It's just bug fix release, and i don't see any api change mentioned in the changelog

I can update it to 3.17.1 with my workaround if you don't mind? (yes, i'm a proven packager :) )

Comment 9 Orion Poplawski 2016-04-14 14:47:18 UTC
Feel free, thanks.

Comment 10 Dan Horák 2016-04-14 17:52:03 UTC
I have fixed the root cause in https://github.com/OPENDAP/libdap4/pull/13 :-)

Comment 11 Dan Horák 2016-04-15 08:44:11 UTC
http://pkgs.fedoraproject.org/cgit/rpms/libdap.git/commit/?id=d535cbfdded93990ecfc3adc1ae4ad01df636039

But a new issue arose - cppunit-devel doesn't provide the cppunit-config script and expects apps will use the pkgconfig file, as result the unit tests are not run in F-24+. Reported as https://github.com/OPENDAP/libdap4/issues/14

Comment 13 Fedora Update System 2016-04-15 21:28:49 UTC
libdap-3.17.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f918c3f1db

Comment 14 Fedora Update System 2016-04-18 04:55:58 UTC
libdap-3.17.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f918c3f1db

Comment 15 Fedora Update System 2016-04-18 09:24:58 UTC
libdap-3.17.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fc3d101da

Comment 16 Fedora Update System 2016-04-18 18:51:06 UTC
libdap-3.17.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fc3d101da

Comment 17 Fedora Update System 2016-04-18 21:54:32 UTC
bes-3.17.0-3.fc24 libdap-3.17.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fc3d101da

Comment 18 Fedora Update System 2016-04-19 20:26:18 UTC
bes-3.17.0-3.fc24, gdal-2.0.2-5.fc24, libdap-3.17.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fc3d101da

Comment 19 Fedora Update System 2016-05-07 12:06:33 UTC
bes-3.17.0-3.fc24, gdal-2.0.2-5.fc24, libdap-3.17.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.