Bug 132512 - Add http proxy blocking to sendmail
Add http proxy blocking to sendmail
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 05:15 EDT by Per Steinar Iversen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 05:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2004-09-14 05:15:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
It is possible to reliably block mail/spam from open http proxies by
adding this lines to the sendmail configuration:

APPENDDEF(`conf_sendmail_ENVDEF', `-D_FFR_BLOCK_PROXIES')

This then causes sendmail to block any smtp session that uses POST,
CONNECT etc. A typical log entry looks like this:

[218.12.171.14]: probable open proxy: command=POST / HTTP/1.0\r\n



Version-Release number of selected component (if applicable):
sendmail-8.13.1-2

How reproducible:
Always

Steps to Reproduce:
1. Receive spam from open http proxy
2.
3.
    

Actual Results:  Spam received

Expected Results:  It could be blocked...

Additional info:

It is hard to believe that email from http proxies is used for
anything but spamming.
Comment 1 Robert Scheck 2006-08-12 12:42:25 EDT
I'm also interested in having this feature enabled per default...*narf*
Bugzilla is believing, I'm adding the keyword FutureFeature.
Comment 2 Thomas Woerner 2007-07-23 05:29:07 EDT
The support for _FFR_BLOCK_PROXIES has been dropped by sendmail.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.