Bug 1325134 - Anaconda disallows installing booloader to offload iSCSI device (qla4xxx)
Summary: Anaconda disallows installing booloader to offload iSCSI device (qla4xxx)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 1269195
Blocks: 1324435 ovirt-node-ng-platform
TreeView+ depends on / blocked
 
Reported: 2016-04-08 11:28 UTC by Fabian Deutsch
Modified: 2016-11-03 23:23 UTC (History)
14 users (show)

Fixed In Version: anaconda-21.48.22.65-1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1324435
Environment:
Last Closed: 2016-11-03 23:23:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2158 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2016-11-03 13:13:55 UTC
Red Hat Bugzilla 1353495 None None None Never

Internal Links: 1353495

Description Fabian Deutsch 2016-04-08 11:28:52 UTC
+++ This bug was initially created as a clone of Bug #1324435 +++

Description of problem:
Anaconda exception occurs on iscsi machine

Version-Release number of selected component (if applicable):
ovirt-node-ng-installer-master-20160405.iso
squashfs.20160405
ovirt-node-ng-image-update-placeholder-4.0.0-0.2.alpha1.20160405123556.gitbd184ec.el7.noarch
imgbased-0.5-0.201604040928gitd6a85f8.el7.centos.noarch
ovirt-release-host-node-4.0.0-0.2.alpha1.20160405123556.gitbd184ec.el7.noarch


How reproducible:
100%

Steps to Reproduce:
1. Boot from PXE and manual install ngn 4.0.
2. Try to finish the installation with correct steps.
3. Focus on the installation process.
4. Please see the attachment for more detail.

Actual results:
Anaconda exception occurs on iscsi machine

Expected results:


Additional info:
No such issue on FC/local machine.

--- Additional comment from shaochen on 2016-04-06 12:42 CEST ---



--- Additional comment from Fabian Deutsch on 2016-04-06 22:52:03 CEST ---

From comment 1 's anaconda.log:

14:13:00,548 INFO anaconda: Installing boot loader
14:13:00,549 DEBUG anaconda: running handleException
14:13:00,550 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)

  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 254, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2383, in writeBootLoader
    log.info("boot loader stage1 target device is %s", stage1_device.name)

AttributeError: 'NoneType' object has no attribute 'name'

14:13:00,551 DEBUG anaconda: Gtk running, queuing exception handler to the main loop

Looks like a bug in anaconda.

Any idea, anaconda team?

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-04-06 22:52:31 CEST ---

This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

--- Additional comment from Radek Vykydal on 2016-04-07 12:01:48 CEST ---

14:09:38,712 DEBUG anaconda: stage1 device cannot be on an iSCSI disk
14:09:40,759 DEBUG anaconda: new disk order: []
14:09:40,809 DEBUG anaconda: stage1 device cannot be of type lvmvg
14:09:40,810 DEBUG anaconda: stage1 device cannot be of type lvmthinlv
14:09:40,810 DEBUG anaconda: stage1 device cannot be of type lvmthinpool
14:09:40,811 DEBUG anaconda: stage1 device cannot be of type lvmthinlv
14:09:40,812 DEBUG anaconda: stage1 device cannot be of type lvmlv
14:09:40,813 DEBUG anaconda: stage1 device cannot be on an iSCSI disk
14:09:40,814 DEBUG anaconda: stage1 device cannot be of type partition
14:09:40,814 DEBUG anaconda: stage1 device cannot be of type partition
14:09:40,815 ERR anaconda: BootLoader setup failed: failed to find a suitable stage1 device

Seems like duplicate of bug 1269195, see esp.
https://bugzilla.redhat.com/show_bug.cgi?id=1269195#c23

--- Additional comment from Radek Vykydal on 2016-04-07 12:22:12 CEST ---

Perhaps we are incorrectly disallowing installing bootloader on offload iSCSI disks.

--- Additional comment from Fabian Deutsch on 2016-04-07 13:02:16 CEST ---

Thanks Rdaek.

Let's keep this bug for tracking prupose on the RHEV-H side.

--- Additional comment from Radek Vykydal on 2016-04-07 14:23:43 CEST ---

Would you be able to test this updates image (for RHEL 7.2) with fix?

It can be applied either by boot option:

updates https://rvykydal.fedorapeople.org/updates.iscsioffload.img

or by kickstart command

updates=https://rvykydal.fedorapeople.org/updates.iscsioffload.img

I think if the case is (as I assume from the logs) an installation to a single (partial?) offload iSCSI device we can reassign the bug to Anaconda. I'm asking for assistance with checking the fix as it is not easy to get to the hw.

--- Additional comment from Radek Vykydal on 2016-04-07 15:52:48 CEST ---

(In reply to Radek Vykydal from comment #7)

Oh sorry,

> Would you be able to test this updates image (for RHEL 7.2) with fix?
> 
> It can be applied either by boot option:
> 
> updates https://rvykydal.fedorapeople.org/updates.iscsioffload.img
> 

this is kickstart command

> or by kickstart command
> 
> updates=https://rvykydal.fedorapeople.org/updates.iscsioffload.img
> 

this is boot option

--- Additional comment from shaochen on 2016-04-08 08:37:44 CEST ---

(In reply to Radek Vykydal from comment #8)
> (In reply to Radek Vykydal from comment #7)
> 
> Oh sorry,
> 
> > Would you be able to test this updates image (for RHEL 7.2) with fix?
> > 
> > It can be applied either by boot option:
> > 
> > updates https://rvykydal.fedorapeople.org/updates.iscsioffload.img
> > 
> 
> this is kickstart command
> 
> > or by kickstart command
> > 
> > updates=https://rvykydal.fedorapeople.org/updates.iscsioffload.img
> > 
> 
> this is boot option

The update image work well on single path iscsi machine, the installation can successful. Please see the attachment "complete-iscis.png" for more detail. 

updates=https://rvykydal.fedorapeople.org/updates.iscsioffload.img

--- Additional comment from shaochen on 2016-04-08 08:38 CEST ---



--- Additional comment from Radek Vykydal on 2016-04-08 09:24:54 CEST ---

Should I create a clone for anaconda or are you OK with reassigning the BZ?

--- Additional comment from Radek Vykydal on 2016-04-08 09:31:26 CEST ---

Also reproducible on storageqe-81.lab.eng.brq.redhat.com.

--- Additional comment from Fabian Deutsch on 2016-04-08 13:27:47 CEST ---

I'll clone it Radek, because we need to track it from the RHEV side.

Comment 2 Radek Vykydal 2016-04-12 09:22:27 UTC
Requires python-blivet 0.61.15.42.

Comment 11 Fedora Update System 2016-09-14 17:27:46 UTC
python-blivet-2.1.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a6fff27e83

Comment 12 Fedora Update System 2016-09-16 01:25:07 UTC
python-blivet-2.1.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a6fff27e83

Comment 14 Fedora Update System 2016-09-20 18:57:31 UTC
python-blivet-2.1.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d8691b1b14

Comment 15 Fedora Update System 2016-09-22 09:56:42 UTC
python-blivet-2.1.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d8691b1b14

Comment 17 errata-xmlrpc 2016-11-03 23:23:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html


Note You need to log in before you can comment on or make changes to this bug.