Bug 1325135 - Corrupted aux-cache causes ldconfig to segfault
Summary: Corrupted aux-cache causes ldconfig to segfault
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Carlos O'Donell
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On: 1325138
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-08 11:41 UTC by Deepu K S
Modified: 2019-10-10 11:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1325138 (view as bug list)
Environment:
Last Closed: 2016-04-08 16:11:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Sourceware 18093 0 None None None 2019-04-09 09:17:16 UTC
Sourceware 20890 0 None None None 2019-04-09 09:17:16 UTC

Description Deepu K S 2016-04-08 11:41:03 UTC
Description of problem:
ldconfig segfaults if the /var/cache/ldconfig/aux-cache is corrupted.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 6
glibc-2.12-1.166.el6_7.7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Remove some entries from /var/cache/ldconfig/aux-cache to make corrupt file.
2. Run ldconfig to rebuild cache
3.

Actual results:
# ldconfig 
Segmentation fault (core dumped)

Expected results:
ldconfig should check for corrupt cache and rebuild it again.

Additional info:
https://sourceware.org/bugzilla/show_bug.cgi?id=18093

Comment 1 Carlos O'Donell 2016-04-08 16:11:31 UTC
The workaround is to remove the aux-cache and re-run ldconfig. More importantly you need to determine the root cause of the filesystem corruption.

We are beyond the RHEL 6.8 planning phase and so this issue would move to be fixed in RHEL 6.9. However, RHEL 6.9 is in production phase 2, and this issue would not qualify for an urgent priority bug fix. Therefore I am closing this as CLSOED/WONTFIX.

We have cloned this issue to fix it in rhel-7.4.

Comment 2 Carlos O'Donell 2016-04-08 16:16:40 UTC
(In reply to Carlos O'Donell from comment #1)
> We have cloned this issue to fix it in rhel-7.4.

Let me rephrase that as:
We have cloned this issue to consider addressing it in the RHEL-7 product.


Note You need to log in before you can comment on or make changes to this bug.