This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 132521 - mozilla sometimes hangs, parsing all desktop files
mozilla sometimes hangs, parsing all desktop files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-14 08:52 EDT by Harald Hoyer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 10:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2004-09-14 08:52:52 EDT
Happened yesterday also with:
$ rpm -q mozilla
mozilla-1.7.2-0.3.0


example backtrace from an older version:

#0  0x00af1ae5 in strncpy () from /lib/tls/libc.so.6
#1  0x0501e0f7 in egg_desktop_entries_get_boolean_list ()
   from /usr/lib/libgnomevfs-2.so.0
#2  0x0501e6c5 in egg_desktop_entries_flush_parse_buffer ()
   from /usr/lib/libgnomevfs-2.so.0
#3  0x0501eab7 in egg_desktop_entries_parse_data ()
   from /usr/lib/libgnomevfs-2.so.0
#4  0x0501ec54 in egg_desktop_entries_new_from_file ()
   from /usr/lib/libgnomevfs-2.so.0
#5  0x0503746b in gnome_vfs_mime_set_extensions_list ()
   from /usr/lib/libgnomevfs-2.so.0
#6  0x05037c7f in gnome_vfs_mime_set_extensions_list ()
   from /usr/lib/libgnomevfs-2.so.0
#7  0x05037cec in gnome_vfs_mime_set_extensions_list ()
   from /usr/lib/libgnomevfs-2.so.0
#8  0x0503d6e0 in _gnome_vfs_monitor_do_cancel ()
   from /usr/lib/libgnomevfs-2.so.0
#9  0x00d54848 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#10 0x00d514fb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#11 0x00d52f82 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#12 0x00d5322f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#13 0x06fad1de in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x003afacc in nsAppShell::ReleaseGlobals ()
   from /usr/lib/mozilla-1.7.2/components/libwidget_gtk2.so
#15 0x0046171a in ?? ()
   from /usr/lib/mozilla-1.7.2/components/libnsappshell.so
#16 0x0981c438 in ?? ()
#17 0x08063c74 in nsISplashScreen::GetIID()::iid ()
#18 0x00000000 in ?? ()
#19 0x00000000 in ?? ()
#20 0xfef256a0 in ?? ()
#21 0xfef25898 in ?? ()
#22 0x08053460 in DoCommandLines ()
#23 0x08053460 in DoCommandLines ()
#24 0x08053dac in main ()
(gdb)
Comment 1 Daniel Veillard 2004-09-21 10:31:54 EDT
I'm suspicious of the call to gnome_vfs_monitor_do_cancel()
especially after 132922 and 130967 . Do you still have
the system ? If the gamin version was < 0.0.9 I bet it's a 
duplicate of those bugs. In any case it would be good if you could
tell me if this happened too with a recent version of the gamin
package.

  thanks,

Daniel
Comment 2 Harald Hoyer 2004-09-21 10:42:15 EDT
didn't occure lately... 
$ rpm -q gamin
gamin-0.0.9-1

if it does happen again, I'll reopen.
Comment 3 Harald Hoyer 2004-09-22 09:47:59 EDT
happened again... now with thunderbird:
(gdb) bt
#0  0x00a8a2e2 in strncpy () from /lib/tls/libc.so.6
#1  0x0141d1b2 in egg_desktop_entries_get_boolean_list ()
   from /usr/lib/libgnomevfs-2.so.0
#2  0x0141d77e in egg_desktop_entries_flush_parse_buffer ()
   from /usr/lib/libgnomevfs-2.so.0
#3  0x0141db70 in egg_desktop_entries_parse_data ()
   from /usr/lib/libgnomevfs-2.so.0
#4  0x0141dd0d in egg_desktop_entries_new_from_file ()
   from /usr/lib/libgnomevfs-2.so.0
#5  0x01436b58 in gnome_vfs_mime_set_extensions_list ()
   from /usr/lib/libgnomevfs-2.so.0
#6  0x014378e7 in gnome_vfs_mime_get_all_desktop_entries ()
   from /usr/lib/libgnomevfs-2.so.0
#7  0x01434df0 in gnome_vfs_mime_get_default_application ()
   from /usr/lib/libgnomevfs-2.so.0
#8  0x00ef9851 in nsGNOMERegistry::GetFromType ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#9  0x00ef9c37 in nsGNOMERegistry::GetFromExtension ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#10 0x00ef83a9 in nsOSHelperAppService::GetFromExtension ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#11 0x00ef8f75 in nsOSHelperAppService::GetMIMEInfoFromOS ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#12 0x00ef06ee in
nsExternalHelperAppService::GetMIMEInfoForMimeTypeFromDS ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#13 0x00eee386 in nsExternalAppHandler::GetNeverAskFlagFromPref ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#14 0x00ee9c2b in nsExternalHelperAppService::CreateNewExternalHandler ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#15 0x00eed40d in nsExternalAppHandler::CreateProgressListener ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#16 0x091d544e in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libnecko.so
#17 0x091d560d in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libnecko.so
#18 0x091d5879 in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libnecko.so
#19 0x011174b7 in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libmail.so
#20 0x00ee520e in nsDocumentOpenInfo::Open ()
   from /usr/lib/thunderbird-0.8.0/components/libdocshell.so
#21 0x09208bd0 in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libnecko.so
#22 0x091b0bcf in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libnecko.so
#23 0x091b0eb3 in NSGetModule ()
   from /usr/lib/thunderbird-0.8.0/components/libnecko.so
#24 0x00cfacb7 in nsInputStreamReadyEvent::EventHandler ()
   from /usr/lib/thunderbird-0.8.0/libxpcom.so
#25 0x00d0cb93 in PL_HandleEvent ()
   from /usr/lib/thunderbird-0.8.0/libxpcom.so
#26 0x00d0d1f7 in PL_ProcessPendingEvents ()
   from /usr/lib/thunderbird-0.8.0/libxpcom.so
Comment 4 Daniel Veillard 2004-09-22 09:56:49 EDT
Hum, that doesn't look related to monitoring there.
I don't think it's gamin related in that case,

Daniel
Comment 5 Harald Hoyer 2004-09-22 10:24:29 EDT
well the function name gnome_vfs_mime_get_all_desktop_entries() says
it all.. maybe I have to live with that...
Comment 6 Christopher Aillon 2005-05-04 16:41:59 EDT
Is this still an issue?  There have been a bunch of fixes to this code since
thunderbird 0.8, and I just added another patch to the helper apps code to make
things take a slightly different code path to use newer gnome-vfs-2.10 apis.
Comment 7 Harald Hoyer 2005-05-09 07:52:01 EDT
much better in rawhide, was still an issue in FC3
Comment 8 Christopher Aillon 2005-05-09 10:39:30 EDT
Cool.  Marking as RAWHIDE, then.

Note You need to log in before you can comment on or make changes to this bug.