Bug 1325350 - DNF Reposync does complete sync/download but doesn't save any packages
DNF Reposync does complete sync/download but doesn't save any packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
25
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-08 09:37 EDT by Stefan Kirrmann
Modified: 2017-02-15 06:40 EST (History)
7 users (show)

See Also:
Fixed In Version: dnf-plugins-core-1.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-15 06:40:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Kirrmann 2016-04-08 09:37:45 EDT
Description of problem:


Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.20-1.fc24.noarch

How reproducible:


Steps to Reproduce:
1. dnf reposync --repoid foo -p /mnt/test
2. ls -l /mnt/test/foo/

Actual results:
dnf takes as long as it needs to download e.g. several GB of data, but no package is saved at the specified path.


Expected results:
The directory should contain all downloaded packages.


Additional info:
The bug results from the missing option keepcache=true in /etc/dnf.conf

This should not be the case. At least exit the program with a warning saying that the option is missing. But better would be to just override the keepcache option, because a reposync is always done on purpose.
Comment 1 Michal Luscon 2016-04-11 07:25:57 EDT
Right, the plugin should override this option.
Comment 3 Jan Kurik 2016-07-26 00:47:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 4 Honza Silhan 2017-02-15 06:40:37 EST
fixed in dnf-plugins-core-1.0.1-1 in rawhide (f26).

Note You need to log in before you can comment on or make changes to this bug.