Bug 1325471 - resolving Supplements: dependencies pull in multilib packages
Summary: resolving Supplements: dependencies pull in multilib packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsolv
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker AcceptedFreezeExcepti...
: 1320755 (view as bug list)
Depends On:
Blocks: F24BetaFreezeException F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-04-09 01:09 UTC by Steven Haigh
Modified: 2016-05-20 23:50 UTC (History)
15 users (show)

Fixed In Version: libsolv-0.6.20-2.fc24 libsolv-0.6.20-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-20 17:36:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1325666 None None None Never

Internal Links: 1325666

Description Steven Haigh 2016-04-09 01:09:58 UTC
Description of problem:
When installing okular from the command line, dnf tries to bring in a whole heap of the i686 world with it.

Version-Release number of selected component (if applicable):
okular-15.12.3-1.fc24.x86_64

When running 'dnf install okular', the following is performed:
Last metadata expiration check: 0:38:00 ago on Fri Apr  8 23:56:24 2016.
Dependencies resolved.
================================================================================
 Package               Arch   Version                              Repository
                                                                           Size
================================================================================
Installing:
 OpenEXR-libs          i686   2.2.0-5.fc24                         fedora 657 k
 alsa-lib              i686   1.1.1-1.fc24                         fedora 411 k
 attica                i686   0.4.2-9.fc24                         fedora 207 k
 audit-libs            i686   2.5-3.fc24                           fedora  96 k
 bzip2-libs            i686   1.0.6-20.fc24                        fedora  46 k
 cairo                 i686   1.14.6-1.fc24                        updates-testing
                                                                          754 k
 cdparanoia-libs       i686   10.2-21.fc24                         fedora  57 k
 chmlib                x86_64 0.40-13.fc24                         fedora  50 k
 clucene09-core        i686   0.9.21b-16.fc24                      fedora 319 k
 cracklib              i686   2.9.6-2.fc24                         fedora  85 k
 dbus-libs             i686   1:1.11.2-1.fc24                      fedora 177 k
 dbusmenu-qt           i686   0.9.3-0.11.20150604.fc24             fedora  97 k
 djvulibre-libs        x86_64 3.5.25.3-18.fc24                     fedora 590 k
 enchant               i686   1:1.6.0-13.fc24                      fedora  61 k
 exiv2-libs            i686   0.25-3.fc24                          fedora 1.5 M
 expat                 i686   2.1.0-13.fc24                        fedora  94 k
 flac-libs             i686   1.3.1-6.fc24                         fedora 220 k
 fontconfig            i686   2.11.94-6.fc24                       fedora 247 k
 freetype              i686   2.6.3-2.fc24                         fedora 366 k
 gamin                 i686   0.1.10-22.fc24                       fedora 123 k
 giflib                i686   4.1.6-15.fc24                        fedora  45 k
 glib2                 i686   2.48.0-1.fc24                        fedora 2.2 M
 glibc                 i686   2.23.1-5.fc24                        fedora 4.3 M
 graphite2             i686   1.3.6-1.fc24                         fedora 117 k
 gsm                   i686   1.0.13-14.fc24                       fedora  35 k
 gstreamer1            i686   1.8.0-1.fc24                         fedora 1.1 M
 gstreamer1-plugins-base
                       i686   1.8.0-1.fc24                         fedora 1.4 M
 harfbuzz              i686   1.2.4-1.fc24                         updates-testing
                                                                          224 k
 herqq                 i686   1.0.0-13.fc24                        fedora 355 k
 hunspell              i686   1.3.3-9.fc24                         fedora 223 k
 ilmbase               i686   2.2.0-5.fc24                         fedora 105 k
 jasper-libs           i686   1.900.1-32.fc24                      fedora 149 k
 jbigkit-libs          i686   2.1-5.fc24                           fedora  52 k
 json-c                i686   0.12-7.fc24                          fedora  31 k
 kactivities-libs      x86_64 4.13.3-20.fc24                       fedora  72 k
 kate4-part            i686   4.14.3-16.fc24                       fedora 2.0 M
 kde-platform-plugin   i686   1:4.11.22-9.fc24                     fedora  90 k
 kde-runtime           x86_64 15.12.3-1.fc24                       fedora 5.6 M
 kde-runtime-drkonqi   x86_64 15.12.3-1.fc24                       fedora 234 k
 kde-runtime-flags     noarch 15.12.3-1.fc24                       fedora 144 k
 kde-runtime-libs      x86_64 15.12.3-1.fc24                       fedora 1.4 M
 kde-style-breeze      i686   5.5.5-3.fc24                         fedora 195 k
 kdelibs               i686   6:4.14.18-2.fc24                     fedora  12 M
 kdelibs-ktexteditor   i686   6:4.14.18-2.fc24                     fedora  84 k
 kdelibs-webkit        i686   6:4.14.18-2.fc24                     fedora  66 k
 kdepimlibs-gpgme      x86_64 4.14.10-9.fc24                       fedora 116 k
 kdepimlibs-kxmlrpcclient
                       x86_64 4.14.10-9.fc24                       fedora  30 k
 keyutils-libs         i686   1.5.9-8.fc24                         fedora  45 k
 kio_msits             x86_64 7:15.12.3-1.fc24                     fedora  29 k
 krb5-libs             i686   1.14.1-5.fc24                        updates-testing
                                                                          861 k
 lcms2                 i686   2.7-3.fc24                           fedora 155 k
 libICE                i686   1.0.9-5.fc24                         fedora  70 k
 libSM                 i686   1.2.2-4.fc24                         fedora  43 k
 libX11                i686   1.6.3-3.fc24                         fedora 616 k
 libXScrnSaver         i686   1.2.2-10.fc24                        fedora  28 k
 libXau                i686   1.0.8-6.fc24                         fedora  34 k
 libXcursor            i686   1.1.14-6.fc24                        fedora  35 k
 libXdamage            i686   1.1.4-8.fc24                         fedora  25 k
 libXext               i686   1.3.3-4.fc24                         fedora  43 k
 libXfixes             i686   5.0.1-6.fc24                         fedora  23 k
 libXft                i686   2.3.2-4.fc24                         fedora  62 k
 libXi                 i686   1.7.6-2.fc24                         fedora  46 k
 libXinerama           i686   1.1.3-6.fc24                         fedora  18 k
 libXpm                i686   3.5.11-5.fc24                        fedora  53 k
 libXrandr             i686   1.5.0-3.fc24                         fedora  31 k
 libXrender            i686   0.9.9-3.fc24                         fedora  31 k
 libXtst               i686   1.2.2-6.fc24                         fedora  25 k
 libXv                 i686   1.0.10-4.fc24                        fedora  22 k
 libXxf86vm            i686   1.1.4-3.fc24                         fedora  22 k
 libacl                i686   2.2.52-11.fc24                       fedora  32 k
 libasyncns            i686   0.8-10.fc24                          fedora  31 k
 libattr               i686   2.4.47-16.fc24                       fedora  24 k
 libcap                i686   2.24-9.fc24                          fedora  53 k
 libcom_err            i686   1.42.13-4.fc24                       fedora  45 k
 libdatrie             i686   0.2.9-3.fc24                         updates-testing
                                                                           32 k
 libdb                 i686   5.3.28-14.fc24                       fedora 770 k
 libdrm                i686   2.4.67-3.fc24                        fedora 153 k
 libffi                i686   3.1-9.fc24                           fedora  34 k
 libgcc                i686   6.0.0-0.19.fc24                      fedora  90 k
 libgcrypt             i686   1.6.4-2.fc24                         fedora 355 k
 libgpg-error          i686   1.21-2.fc24                          fedora 159 k
 libidn                i686   1.32-2.fc24                          fedora 233 k
 libjpeg-turbo         i686   1.4.2-3.fc24                         fedora 158 k
 libkexiv2             x86_64 15.08.3-2.fc24                       fedora 265 k
 libkscreen            x86_64 1:1.0.5-6.fc24                       fedora  92 k
 libmng                i686   2.0.3-3.fc24                         fedora 184 k
 libogg                i686   2:1.3.2-5.fc24                       fedora  29 k
 libpciaccess          i686   0.13.4-3.fc24                        fedora  32 k
 libpng                i686   2:1.6.21-2.fc24                      fedora 124 k
 libqzeitgeist         i686   0.8.0-15.fc24                        fedora  78 k
 libseccomp            i686   2.3.0-1.fc24                         fedora  58 k
 libselinux            i686   2.5-2.fc24                           fedora 164 k
 libsepol              i686   2.5-2.fc24                           fedora 295 k
 libsndfile            i686   1.0.25-20.fc24                       fedora 172 k
 libspectre            x86_64 0.2.7-8.fc24                         fedora  45 k
 libstdc++             i686   6.0.0-0.19.fc24                      fedora 456 k
 libthai               i686   0.1.24-1.fc24                        fedora 197 k
 libtheora             i686   1:1.1.1-14.fc24                      fedora 188 k
 libtiff               i686   4.0.6-2.fc24                         fedora 180 k
 libutempter           i686   1.1.6-8.fc24                         fedora  30 k
 libuuid               i686   2.28-0.3.fc24                        fedora  80 k
 libverto              i686   0.2.6-6.fc24                         fedora  21 k
 libvisual             i686   1:0.4.0-20.fc24                      fedora 143 k
 libvorbis             i686   1:1.3.4-6.fc24                       fedora 185 k
 libwayland-client     i686   1.10.0-1.fc24                        fedora  33 k
 libwayland-server     i686   1.10.0-1.fc24                        fedora  38 k
 libwebp               i686   0.5.0-2.fc24                         fedora 248 k
 libxcb                i686   1.11.1-2.fc24                        fedora 205 k
 libxml2               i686   2.9.3-3.fc24                         fedora 694 k
 libxshmfence          i686   1.2-3.fc24                           fedora  12 k
 libxslt               i686   1.1.28-12.fc24                       fedora 246 k
 lz4                   i686   r131-2.fc24                          fedora  86 k
 mesa-libEGL           i686   11.2.0-0.devel.12.24ea81a.fc24       fedora 110 k
 mesa-libGL            i686   11.2.0-0.devel.12.24ea81a.fc24       fedora 186 k
 mesa-libgbm           i686   11.2.0-0.devel.12.24ea81a.fc24       fedora  58 k
 mesa-libglapi         i686   11.2.0-0.devel.12.24ea81a.fc24       fedora  74 k
 ncurses-libs          i686   6.0-4.20160116.fc24                  fedora 332 k
 nss-softokn-freebl    i686   3.23.0-1.0.fc24                      fedora 200 k
 okular                x86_64 15.12.3-1.fc24                       fedora 495 k
 okular-libs           x86_64 15.12.3-1.fc24                       fedora 304 k
 okular-part           x86_64 15.12.3-1.fc24                       fedora 1.0 M
 openssl-libs          i686   1:1.0.2g-3.fc24                      fedora 1.0 M
 opus                  i686   1.1.2-2.fc24                         fedora 183 k
 orc                   i686   0.4.25-1.fc24                        fedora 176 k
 pam                   i686   1.2.1-5.fc24                         fedora 734 k
 pango                 i686   1.40.0-1.fc24                        fedora 283 k
 pcre                  i686   8.38-11.fc24                         fedora 403 k
 phonon                i686   4.8.3-9.fc24                         fedora 218 k
 phonon-backend-gstreamer
                       i686   2:4.8.2-6.fc24                       fedora 157 k
 pixman                i686   0.34.0-2.fc24                        fedora 264 k
 polkit-libs           i686   0.113-5.fc24                         fedora  69 k
 polkit-qt             i686   0.112.0-7.fc24                       fedora  78 k
 poppler-qt            x86_64 0.41.0-1.fc24                        fedora 172 k
 proj                  i686   4.9.2-2.fc24                         fedora 205 k
 pulseaudio-libs       i686   8.0-6.fc24                           fedora 578 k
 pulseaudio-libs-glib2 i686   8.0-6.fc24                           fedora  24 k
 qca                   i686   2.1.1-4.fc24                         fedora 486 k
 qimageblitz           x86_64 0.0.6-11.fc24                        fedora  61 k
 qjson                 x86_64 0.8.1-16.20150318.d0f62e6git.fc24    fedora  68 k
 qmobipocket           x86_64 15.12.3-1.fc24                       fedora  32 k
 qt                    i686   1:4.8.7-12.fc24                      fedora 5.1 M
 qt-mobility-common    i686   1.2.2-0.23.20140317git169da60c.fc24  fedora  40 k
 qt-mobility-location  i686   1.2.2-0.23.20140317git169da60c.fc24  fedora 594 k
 qt-mobility-sensors   i686   1.2.2-0.23.20140317git169da60c.fc24  fedora 129 k
 qt-x11                i686   1:4.8.7-12.fc24                      fedora  13 M
 qtsoap                i686   2.7-13.fc24                          fedora  82 k
 qtwebkit              i686   2.3.4-11.fc24                        fedora  21 M
 sni-qt                i686   0.2.6-7.fc24                         fedora  61 k
 sqlite-libs           i686   3.11.0-3.fc24                        fedora 468 k
 strigi-libs           i686   0.7.8-12.fc24                        fedora 478 k
 systemd-libs          i686   229-7.fc24                           fedora 481 k
 tcp_wrappers-libs     i686   7.6-83.fc24                          fedora  72 k
 xz-libs               i686   5.2.2-2.fc24                         fedora  98 k
 zlib                  i686   1.2.8-10.fc24                        fedora  98 k

Transaction Summary
================================================================================
Install  154 Packages

Total download size: 97 M
Installed size: 306 M
Is this ok [y/N]: 

The i686 universe is not installed if you run:
    dnf install okular --exclude='*.86_64'

Comment 1 Rex Dieter 2016-04-09 01:16:50 UTC
I'm pretty sure this isn't expected behavior, re-assigning to dnf for advice/comment

also, the --exclude above should be --exclude=*.i686

Comment 2 Rex Dieter 2016-04-09 22:15:25 UTC
Hrm, I hit the same thing on a pure 'dnf update' operation today,

I suspect it may have to do with recently-introduced rich/soft dependencies in some qt/kde related packages.

Yep, seems so,

sudo dnf update  --exclude=kde-platform-plugin

makes it work as expected.

So, kde-platform-plugin includes:

Supplements: (kde-runtime and plasma-workspace)

What I have currently installed:

$ rpm -q kde-runtime plasma-workspace kde-platform-plugin
kde-runtime-15.12.3-1.fc24.x86_64
plasma-workspace-5.5.5-10.fc24.x86_64
kde-platform-plugin-4.11.22-9.fc24.x86_64

My update transaction tries to pull in a newer plasma-workspace, but I do *not* expect it to want to pull in kde-platform-plugin.i686 on a x86_64 system.

Comment 3 Rex Dieter 2016-04-09 22:16:34 UTC
Would something like this work better?

Supplements: (kde-runtime%{?_isa} and plasma-workspace%{?_isa})

I suspect not, since those are just virtual Provides and not real packages.

Comment 4 Rex Dieter 2016-04-09 22:36:55 UTC
If dnf devs can confirm this is expected behavior and not a bug, then we can consider other options.

Comment 5 Rex Dieter 2016-04-09 22:39:57 UTC
adjusting Summary to match my findings, I'll be submitting this as a f24 blocker

Comment 6 Fedora Blocker Bugs Application 2016-04-09 22:43:17 UTC
Proposed as a Blocker for 24-final by Fedora user rdieter using the blocker tracking app because:

 Unsure if there's a specific criterion that covers this but... due to how dnf resolves (soft) Supplements: dependencies, it will pull in *all* providers, including multilib ones.  My own expectation is that only native arch packages should get installed in this case.

Comment 7 Igor Gnatenko 2016-04-11 11:16:45 UTC
Bug 1325666 looks very similar.

Comment 8 Steven Haigh 2016-04-11 11:19:41 UTC
As a current workaround, I have added the following to each enabled repo in /etc/yum.repos.d/*.repo:
    exclude=*.i686

Although this isn't a great idea - I've added it here to assist others that have the same problem and need a workaround.

This solved the problem of pulling in a ton of i686 updates today via a 'dnf -y update' on F24A.

Comment 9 Kamil Páral 2016-04-11 16:41:25 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Final) AcceptedFreezeException (Beta) - details are not nailed down yet, but installing a ton of multilib packages on system update is considered a conditional violation of "The installed system must be able to download and install updates with the default console package manager." and accepted as a Final blocker and Beta freeze exception for now. decision may be changed based on later info

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-04-11/

Comment 10 Tomas Toth 2016-04-11 17:44:26 UTC
I hit the same/similar issue on my F24 KDE x86_64 (alpha) in VM with dnf update.

The --exclude=*.i686 workaround worked.

I have the debugdata stored from both:
dnf update --debugsolver
dnf update --debugsolver --exclude=*.i686

Let me know if you need them.

Comment 11 Fedora Update System 2016-04-12 00:44:13 UTC
kdelibs-4.14.18-3.fc24 kde-workspace-4.11.22-10.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-71fd10b77c

Comment 12 Rex Dieter 2016-04-12 00:46:13 UTC
The aforementioned update strictly doesn't fix this, is only really a workaround, but avoiding the use of the problematic Supplements: tag

Comment 13 Fedora Update System 2016-04-12 10:52:09 UTC
kde-workspace-4.11.22-10.fc24, kdelibs-4.14.18-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-71fd10b77c

Comment 14 Steven Haigh 2016-04-12 11:01:30 UTC
This probably shouldn't go to ON_QA for a band-aid workaround....

Sadly, I can't mark it as anything but closed though....

Comment 15 Fedora Update System 2016-04-15 21:32:55 UTC
kde-workspace-4.11.22-10.fc24, kdelibs-4.14.18-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Kamil Páral 2016-05-09 16:51:12 UTC
Hello DNF team, is there any progress on this? We're trying to evaluate status of F24 blocker bugs. Thanks.

Comment 17 Kamil Páral 2016-05-17 10:01:00 UTC
I talked to jsilhan on IRC and they are now aware of this. Hopefully this being a blocker will increase its priority. Also Michael Schroeder replied and said it's a bug in libsolv and that he's going to fix it upstream.

Comment 18 Fedora Update System 2016-05-17 12:05:53 UTC
libsolv-0.6.20-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c46a2cafe7

Comment 19 Fedora Update System 2016-05-17 12:06:47 UTC
libsolv-0.6.20-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-301d205cce

Comment 20 Kamil Páral 2016-05-17 13:57:52 UTC
I'm not sure how to test this. I tried to install kde-workspace-4.11.22-9.fc24 (the old version with Supplements), but it did not try to pull in any i686 deps.

Rex, could you please either verify this or help me figure out how to do it? Thanks.

Comment 21 Rex Dieter 2016-05-17 14:40:08 UTC
It's not trivial to test, you need some packages that are both multilib'd and use Supplements.  kdelibs/kde-workspace were changed to not use Supplements to avoid this bug. see comment #15

I suppose i can try to put some supplements back into some test packages and create a custom repo that includes both arches and see.  (no promises when I'll be able to do that, I've several other important tasks to work on in the foreseeable future)

Comment 22 Fedora Update System 2016-05-17 22:00:10 UTC
libsolv-0.6.20-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-301d205cce

Comment 23 Fedora Update System 2016-05-17 22:00:16 UTC
libsolv-0.6.20-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c46a2cafe7

Comment 24 Kamil Páral 2016-05-18 08:16:41 UTC
(In reply to Rex Dieter from comment #21)
> It's not trivial to test, you need some packages that are both multilib'd
> and use Supplements.  kdelibs/kde-workspace were changed to not use
> Supplements to avoid this bug. see comment #15

Can't we reuse the older kdelibs/kde-workspace packages to verify this? They're still in koji. I tried it, but don't know how exactly to trigger the original issue. Maybe I need to have something installed that I don't.

Comment 25 Michal Jaegermann 2016-05-18 13:54:07 UTC
It could be that bug 1320755 is another manifestation of the same issue (in a rawhide context).  That bug has attached to it some debugging data which were requested.

Comment 26 Rex Dieter 2016-05-18 13:59:04 UTC
Yes, it appears bug #1320755 is (essentially) a dup of this one, and reported before the workaround(s) landed in comment #15, I'll mark it as such

Comment 27 Rex Dieter 2016-05-18 13:59:33 UTC
*** Bug 1320755 has been marked as a duplicate of this bug. ***

Comment 28 Fedora Update System 2016-05-20 17:36:31 UTC
libsolv-0.6.20-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2016-05-20 23:50:12 UTC
libsolv-0.6.20-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.