Bug 132548 - Rename .desktop title from "The Gimp" to "Gimp Image Editor"
Rename .desktop title from "The Gimp" to "Gimp Image Editor"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-14 14:30 EDT by Seth Nickell
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.4-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 13:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Nickell 2004-09-14 14:30:11 EDT
Gimp's .desktop file should have the title changed "Gimp Image Editor"
Comment 1 Nils Philippsen 2004-09-15 03:38:05 EDT
Agreed, but that would screw up all the translations... I'll file that
upstream -- though it probably shouldn't be the title but the
GenericName that should be set to "Image Editor", shouldn't it?
Comment 2 Seth Nickell 2004-09-15 15:12:43 EDT
It needs to be the title at this point, unfortunately. Menu stuff is
rather confusing across desktops at the moment and the only way to
actually get the change to "take" generally is to change the "Name".
Hopefully this will be resolved eventually.

Changing upstream would be nice, though they have not been
particularly ammenable to this change in the past. However, we should
change it in ours soon whether upstream does or not. We have a number
of other RH-specific changed desktop files (same change: functional
naming) and they get translated reasonably before release.
Comment 3 Seth Nickell 2004-09-15 15:13:28 EDT
(particularly because we'll have to get our translators to do this...
early is better than later wrt to the FC3 release cycle ;-)
Comment 4 Nils Philippsen 2004-09-16 05:22:04 EDT
Whom do I need to nudge about the translations and how are they going
to do it? It's easy with internally developed stuff like s-c-foo, but
I don't know how they'll be getting the translations into this one.
Comment 5 Jonathan Blandford 2004-09-16 14:09:01 EDT
Hi Nils,

Seth apparently CCed me on this one.

It's a pain to get translations in desktop files with our setup.  I
think we should try to get the changed translation upstream, and
change the English version only in the short term.  95%  of the
current translations just say 'GIMP' right now anyway, so just
clarifying the English version should be fine for now.  If upstream
doesn't modify this, then we'll have to find a fix.
Comment 6 Nils Philippsen 2004-09-16 15:44:59 EDT
As Seth already mentioned, upstream probably won't accept changing the
title when adding a GenericName and fixing the DEs is the right thing.
I'll try it with a changed English (and German) title, but IIRC this
caused all translations to vanish during the build process (because
there is no translation for the new string). Maybe some after-the-fact
hacking in the buildroot.
Comment 7 Jonathan Blandford 2004-09-16 16:55:00 EDT
The gimp should ship with the .desktop file already and you should
patch that.  If it doesn't and it requires intltool to create the
.desktop file, then you should prolly just run:

 perl -pi  -e 's/Name=The GIMP/Name=GIMP Image Editor/'
%{_datadir}/applications/gimp-2.0.desktop

in %install.  Seems easiest.
Comment 8 Nils Philippsen 2004-09-16 17:17:24 EDT
gimp-2.0.4-5 with the changes is just building.
Comment 9 Colin Walters 2004-09-24 13:59:42 EDT
Looks good to me, closing.

Note You need to log in before you can comment on or make changes to this bug.