Bug 1325493 - The rendering of the text प्रविण् (= "praviN" typed using mr-itrans transliteration from lib-m17n) looks different in gedit on f23 and f24
Summary: The rendering of the text प्रविण् (= "praviN" typed using mr-itrans translite...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-marathi-fonts   
(Show other bugs)
Version: 24
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-09 07:20 UTC by Mike FABIAN
Modified: 2016-08-25 16:20 UTC (History)
7 users (show)

Fixed In Version: lohit-marathi-fonts-2.94.0-6.fc24 lohit-marathi-fonts-2.94.0-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 12:00:08 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
praviN.txt (23 bytes, text/plain)
2016-04-09 07:20 UTC, Mike FABIAN
no flags Details
praviN-gedit-comparision-f23-f24.png (250.55 KB, image/png)
2016-04-09 07:22 UTC, Mike FABIAN
no flags Details
difference-when-rendering-with-lohit-devanagari-versus-with-lohit-marathi.png (357.49 KB, image/png)
2016-04-11 06:21 UTC, Mike FABIAN
no flags Details
screenshot showing correct rendering of praviN.txt with lohit-marathi-fonts-2.94.0-6.fc24 (456.86 KB, image/png)
2016-04-26 05:59 UTC, sandeep shedmake
no flags Details

Description Mike FABIAN 2016-04-09 07:20:15 UTC
Created attachment 1145361 [details]
praviN.txt

Comment 1 Mike FABIAN 2016-04-09 07:22 UTC
Created attachment 1145362 [details]
praviN-gedit-comparision-f23-f24.png

Left: Fedora 23, gedit-3.18.3-1.fc23.x86_64
Right: Fedora 24 Alpha, gedit-3.19.5-1.fc24.x86_64

Comment 2 Mike FABIAN 2016-04-09 07:23:25 UTC
The text file praviN.txt used is exactly the same in Fedora 23 and Fedora 24 Alpha, but the rendering result in gedit looks different.

Comment 3 Mike FABIAN 2016-04-11 06:21 UTC
Created attachment 1145835 [details]
difference-when-rendering-with-lohit-devanagari-versus-with-lohit-marathi.png

It seems to be a font issue.

This screenshot shows the difference in rendering between

   pango-view --font="Lohit Marathi" praviN.txt

(on top, correct) and

   pango-view --font="Lohit Devanagari" praviN.txt

below, wrong.

Comment 4 Mike FABIAN 2016-04-11 06:25:43 UTC
Parag Nemade wrote that the build of lohit-marathi is the same in 
F23 and F24 and then I noticed that I didn’t have lohit-marathi installed
on my F23 system. If I install it, I get the same problem on F23 as well.

Comment 5 Pravin Satpute 2016-04-12 10:31:09 UTC
I can reproduce issue. Working on finding cause.

Comment 6 Mike FABIAN 2016-04-13 06:33:36 UTC
(In reply to Mike FABIAN from comment #3)
> Created attachment 1145835 [details]
> difference-when-rendering-with-lohit-devanagari-versus-with-lohit-marathi.png
> 
> It seems to be a font issue.
> 
> This screenshot shows the difference in rendering between
> 
>    pango-view --font="Lohit Marathi" praviN.txt
> 
> (on top, correct) and
> 
>    pango-view --font="Lohit Devanagari" praviN.txt
> 
> below, wrong.

Sorry, just the oppsoite, Lohit Marathi renders wrong.

Comment 7 Parag Nemade 2016-04-13 06:46:10 UTC
More test cases is http://utrrs-testing.rhcloud.com/language/mr/gsub showing wrong rendering in firefox.

Comment 8 sandeep shedmake 2016-04-13 08:34:36 UTC
Post anaconda installation of F24 Alpha in Marathi and later after successful gdm login:

- lohit-devanagari-fonts seems installed by default
- lohit-marathi-fonts is not installed by default, but is available and  installable via 'dnf'.

$ rpm -q lohit-devanagari-fonts lohit-marathi-fonts
lohit-devanagari-fonts-2.95.2-2.fc24.noarch
package lohit-marathi-fonts is not installed


$ sudo dnf repoquery -l lohit-devanagari-fonts | grep conf
/etc/fonts/conf.d/65-1-lohit-devanagari.conf
/usr/share/fontconfig/conf.avail/65-1-lohit-devanagari.conf
$ sudo dnf repoquery -l lohit-marathi-fonts | grep conf 
/etc/fonts/conf.d/65-0-lohit-marathi.conf
/usr/share/fontconfig/conf.avail/65-0-lohit-marathi.conf
$ fc-match 
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"


From above, have following query:

As 65-0 has higher weight compared to 65-1, shouldn't 'lohit-marathi-fonts' be installed by default ?


Agreed, broken rendering with 'lohit-marathi-fonts' needs further investigation.

Comment 9 sandeep shedmake 2016-04-13 08:54:16 UTC
$ rpm -q lohit-marathi-fonts
lohit-marathi-fonts-2.94.0-5.fc24.noarch
$ rpm -ql lohit-marathi-fonts | grep ttf
/usr/share/fonts/lohit-marathi/Lohit-Marathi.ttf

Opening 'Lohit-Marathi.ttf' with 'fontforge' reveals no GSUB and GPOS lookups.

Perhaps, I could be missing something.

Else, looking forward ...

Comment 10 Fedora Update System 2016-04-21 14:29:26 UTC
lohit-marathi-fonts-2.94.0-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c7c27be74

Comment 11 Pravin Satpute 2016-04-21 14:36:00 UTC
(In reply to sandeep shedmake from comment #9)
> $ rpm -q lohit-marathi-fonts
> lohit-marathi-fonts-2.94.0-5.fc24.noarch
> $ rpm -ql lohit-marathi-fonts | grep ttf
> /usr/share/fonts/lohit-marathi/Lohit-Marathi.ttf
> 
> Opening 'Lohit-Marathi.ttf' with 'fontforge' reveals no GSUB and GPOS
> lookups.
> 

Good catch. There was error while applying feature file to Lohit-Marathi.sfd. I have resolved errors in .fea file now. So should work properly.

Comment 12 Fedora Update System 2016-04-21 14:36:50 UTC
lohit-marathi-fonts-2.94.0-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-26af2cbd2c

Comment 13 Fedora Update System 2016-04-21 21:55:34 UTC
lohit-marathi-fonts-2.94.0-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c7c27be74

Comment 14 Fedora Update System 2016-04-22 20:57:16 UTC
lohit-marathi-fonts-2.94.0-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-26af2cbd2c

Comment 15 Mike FABIAN 2016-04-25 12:59:22 UTC
The update works.

Comment 16 sandeep shedmake 2016-04-26 05:59 UTC
Created attachment 1150747 [details]
screenshot showing correct rendering of praviN.txt with lohit-marathi-fonts-2.94.0-6.fc24

Comment 17 Fedora Update System 2016-05-07 12:00:05 UTC
lohit-marathi-fonts-2.94.0-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-08-25 16:20:03 UTC
lohit-marathi-fonts-2.94.0-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.