Bug 1325502 - SELinux is preventing mpd from 'getattr' accesses on the directory /root/.config.
Summary: SELinux is preventing mpd from 'getattr' accesses on the directory /root/.con...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 23
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e2a29d135cba069180fd364a819...
: 1358730 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-09 09:56 UTC by Seb L.
Modified: 2016-08-15 16:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-15 16:02:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Seb L. 2016-04-09 09:56:16 UTC
Description of problem:
mpd requires access to /root/.config at startup
SELinux is preventing mpd from 'getattr' accesses on the directory /root/.config.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que mpd devrait être autorisé à accéder getattr sur .config directory par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep mpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:mpd_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /root/.config [ dir ]
Source                        mpd
Source Path                   mpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.12.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.4.6-300.fc23.x86_64 #1 SMP Wed
                              Mar 16 22:10:37 UTC 2016 x86_64 x86_64
Alert Count                   107
First Seen                    2016-01-16 13:01:11 CET
Last Seen                     2016-04-09 11:52:46 CEST
Local ID                      0a252fe0-b9be-4339-a732-f8f521ab7e65

Raw Audit Messages
type=AVC msg=audit(1460195566.599:261): avc:  denied  { getattr } for  pid=6370 comm="mpd" path="/root/.config" dev="dm-1" ino=822702 scontext=system_u:system_r:mpd_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=dir permissive=0


Hash: mpd,mpd_t,config_home_t,dir,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-158.12.fc23.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.6-300.fc23.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2016-04-12 11:06:35 UTC
I cannot reproduce this issue on my F23 system. Is it some your custom configuration of mpd?

Comment 2 Seb L. 2016-04-12 11:25:21 UTC
MPD version is: mpd-0.19.14-1.fc23.x86_64

The two only modifications added to the original /etc/mpd.conf are:
  auto_update  "yes"
[in the pulse audio output section :]
    server     "127.0.0.1"

However I didn't notice that mpd is coming from rpmfusion, so I guess this is a problem with this package. I will file a bug report in rpmfusion's bugzilla, sorry for the confusion!

Comment 3 Lukas Vrabec 2016-08-15 16:01:12 UTC
*** Bug 1358730 has been marked as a duplicate of this bug. ***

Comment 4 Lukas Vrabec 2016-08-15 16:02:55 UTC
Better place for config would be in /etc. Daemon comes from rpmfusion so I closing this as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.