Bug 1325531 - Statedump: Add per xlator ref counting for inode
Summary: Statedump: Add per xlator ref counting for inode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-09 16:59 UTC by Poornima G
Modified: 2017-03-06 17:20 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-06 17:20:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-04-09 16:59:17 UTC
Description of problem:
This is an RFE for adding per xlator ref counting for inode

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-04-09 17:12:18 UTC
REVIEW: http://review.gluster.org/13736 (inode: Add per xlator ref count for inode) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Worker Ant 2016-11-08 04:02:36 UTC
REVIEW: http://review.gluster.org/13736 (inode: Add per xlator ref count for inode) posted (#4) for review on master by Poornima G (pgurusid@redhat.com)

Comment 3 Worker Ant 2017-01-11 05:05:24 UTC
REVIEW: http://review.gluster.org/13736 (inode: Add per xlator ref count for inode) posted (#5) for review on master by Poornima G (pgurusid@redhat.com)

Comment 4 Worker Ant 2017-01-18 09:11:16 UTC
REVIEW: http://review.gluster.org/13736 (inode: Add per xlator ref count for inode) posted (#6) for review on master by Poornima G (pgurusid@redhat.com)

Comment 5 Worker Ant 2017-01-18 09:29:49 UTC
COMMIT: http://review.gluster.org/13736 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit c9239db7961afd648f1fa3310e5ce9b8281c8ad2
Author: Poornima G <pgurusid@redhat.com>
Date:   Tue Mar 15 03:14:16 2016 -0400

    inode: Add per xlator ref count for inode
    
    Debugging inode ref leaks is very difficult as there is no info
    except for the ref count on the inode. Hence this patch is first step
    towards debugging inode ref leaks. With this patch, in the statedump
    we get additional info that tells the ref count taken by each xlator
    on the inode.
    
    Change-Id: I7802f7e7b13c04eb4d41fdf52d5469fd2c2a185a
    BUG: 1325531
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/13736
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 6 Shyamsundar 2017-03-06 17:20:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.