Bug 1325536 - Nova actions don't work for instances running on an upgraded overcloud
Summary: Nova actions don't work for instances running on an upgraded overcloud
Keywords:
Status: CLOSED DUPLICATE of bug 1324739
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-09 19:28 UTC by Marius Cornea
Modified: 2016-04-11 13:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-11 13:18:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Cornea 2016-04-09 19:28:35 UTC
Description of problem:
On an upgraded 7.3 -> 8 overcloud with IPv6 and SSL enabled nova actions don't seem to work:

nova stop gets stuck with:
+--------------------------------------+----------------------------------------------------+--------+--------------+-------------+--------------------------------------------------------------------------------------------------+
| ID                                   | Name                                               | Status | Task State   | Power State | Networks                                                                                         |
+--------------------------------------+----------------------------------------------------+--------+--------------+-------------+--------------------------------------------------------------------------------------------------+
| e77840a3-16e7-43d7-aabd-cf692bfa1c67 | stack01-vm01-e7m4o32flx6k-my_instance-grzhrkgaxtms | ACTIVE | powering-off | Running     | stack01-tenant_net_ext_tagged-6nhgb6atedw6-private_network-orpaxopacser=10.10.10.5, 172.29.0.102 |

nova console-log stack01-vm03-7ugy44tktpw6-my_instance-hle7zkkgfbmv:
ERROR (ConnectFailure): Unable to establish connection to https://[2001:db8:fd00:1000::10]:13774/v2/148059d8eac544b4bc422ad3d894c086/servers/ed166417-8149-4c5f-9c85-1f078113d742/action


nova get-vnc-console stack01-vm03-7ugy44tktpw6-my_instance-hle7zkkgfbmv novnc
ERROR (ConnectFailure): Unable to establish connection to https://[2001:db8:fd00:1000::10]:13774/v2/148059d8eac544b4bc422ad3d894c086/servers/ed166417-8149-4c5f-9c85-1f078113d742/action

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.14-7.el7ost.noarch

How reproducible:
100% 

Steps to Reproduce:
1. Deploy IPv6+SSL overcloud with OSPd 7.3
2. Upgrade deployment to version 8
3. Run nova actions for existing running instances on the overcloud

Actual results:
The commands fail.

Expected results:
I am able to manage running instances.

Comment 2 Marius Cornea 2016-04-11 13:18:13 UTC
Closing this as a duplicate as most probably has the same root cause as BZ#1324739

*** This bug has been marked as a duplicate of bug 1324739 ***


Note You need to log in before you can comment on or make changes to this bug.