Bug 132572 - Plugging in mass storage device causes HAL to stop responding
Plugging in mass storage device causes HAL to stop responding
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-14 15:23 EDT by John (J5) Palmieri
Modified: 2015-01-04 17:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 22:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hal daemon output (46.43 KB, text/plain)
2004-09-14 15:28 EDT, John (J5) Palmieri
no flags Details
/var/log/messages output (10.25 KB, text/plain)
2004-09-14 15:28 EDT, John (J5) Palmieri
no flags Details
lshsl output (50.62 KB, text/plain)
2004-09-14 15:29 EDT, John (J5) Palmieri
no flags Details

  None (edit)
Description John (J5) Palmieri 2004-09-14 15:23:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
Plugging a massstorage device in, pulling it out and then plugging it
in again causes hal to stop working.

Version-Release number of selected component (if applicable):
hal-0.2.97.cvs20040901-1

How reproducible:
Always

Steps to Reproduce:
1. Plug in a USB mass storage device
2. take it out 
3. plug it back in again
    

Actual Results:  Device works the first time then hal hangs and the
device is not mounted the second time.

Expected Results:  Device is mounted

Additional info:
Comment 1 John (J5) Palmieri 2004-09-14 15:28:01 EDT
Created attachment 103841 [details]
Hal daemon output
Comment 2 John (J5) Palmieri 2004-09-14 15:28:42 EDT
Created attachment 103842 [details]
/var/log/messages output
Comment 3 John (J5) Palmieri 2004-09-14 15:29:12 EDT
Created attachment 103843 [details]
lshsl output
Comment 4 David Zeuthen 2004-09-14 19:19:13 EDT
Hi, is it possible to get an strace from hald from just before the
process stops responding? Also, when hald hangs is it possible to kill
the process? Even with -9?
Comment 5 John (J5) Palmieri 2004-09-15 14:35:12 EDT
Can't get an strace or kill it.  Trying to attach to the process with
gdb hangs gdb and I have to kill it with -9.  
Comment 6 David Zeuthen 2004-09-21 03:46:47 EDT
Please try to get the strace with the device in question (Ed's Cruzer
IIRC).
Comment 7 John (J5) Palmieri 2004-09-22 13:29:20 EDT
Reassigning to kernel.  It seems the 256mb version of the cruzer mini
causes a kernel oops.  I also linked to an strace of hal while
plugging in and out the USB drive.  It is over 2 megs so I decided to
just post it on my peoples page.  It looks like hal blocks on a read
of the device.

http://people.redhat.com/johnp/hal.strace
Comment 8 David Zeuthen 2004-09-22 13:39:00 EDT
Interesting. hald locks up on a read on /proc/bus/usb/devices. We
shouldn't really be reading that file anymore now that 2.6.6 and later
contains my patch for the sys files we need. I suppose the oops causes
this behaviour?
Comment 9 Sitsofe Wheeler 2004-12-15 06:00:15 EST
Similar symptoms reported in bug #132572 but without the kernel oops.
Comment 10 Dave Jones 2005-10-05 22:53:45 EDT
I've been using a 256MB cruzer on a daily basis for months without problems, so
I guess this is safe to close.  Please reopen if its still causing problems for you.

Note You need to log in before you can comment on or make changes to this bug.