Bug 1326 - Impossible to upgrade util-linux
Impossible to upgrade util-linux
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-25 09:18 EST by p929001
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-24 19:16:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description p929001 1999-02-25 09:18:52 EST
I have been trying to upgrade to util-linux-2.8-11, but I
keep getting

# rpm -U util-linux-2.8-11.i386.rpm
unpacking of archive failed on file /bin/login: -2147483639:
Operation not permitted
error: util-linux-2.8-11.i386.rpm cannot be installed
#

I am doing this as root, of course. I have tried chmod'ing
and rm'ing /bin/login, but this is impossible, also in
single user mode and when booting from the boot disk in
rescue mode and subsequently mounting the hard disk volume.

The permissions for /bin/login are:

-rws--x--x   1 root root252040 Oct 23 1997 /bin/login*

Please write me if you need further infomartion
Comment 1 David Lawrence 1999-02-25 16:01:59 EST
Sounds like the rpm package update may be corrupt. Try obtaining
another copy and running

rpm -K <package name>

and that will tell you if the package tranferred correctly.
Comment 2 p929001 1999-02-26 06:04:59 EST
The result was:

# rpm -K util-linux-2.8-11.i386.rpm
util-linux-2.8-11.i386.rpm: size (PGP) md5 OK (MISSING KEYS)

I'm not very familiar with PGP; this may be the reason for the missing
keys. Anyway, this new copy gives the same result as the old one.
Comment 3 Jeff Johnson 1999-03-11 15:08:59 EST
Usually these erros are "Out of disk space". If you upgrade
to a later version of rpm (2.5.7) from rpm.redhat.com you
should get a decoded text message of -2147483639

------- Additional Comments From   03/16/99 09:16 -------
I am not out of disk space; I have approx. 176 MB free.
rpm.redhat.com only had version 2.5.6, but it changed the error
message:

unpacking of archive failed on file /bin/login: cpio: unlink failed -
Operation not permitted
error: util-linux-2.8-11.i386.rpm cannot be installed

Using the -vv option gave:

# rpm -vv -U util-linux-2.8-11.i386.rpm
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
D: finding source and binary packages
D: New Header signature
D: Signature size: 236
D: Signature pad : 4
D: sigsize         : 240
D: Header + Archive: 310635
D: expected size   : 310635
D: found 0 source and 1 binary packages
D: opening database mode: 0102
D: opening database in //var/lib/rpm/
D: dependencies: looking for pam
D: dependencies: looking for ld-linux.so.2
D: dependencies: looking for libc.so.6
D: dependencies: looking for libcrypt.so.1
D: dependencies: looking for libdl.so.2
D: dependencies: looking for libm.so.6
D: dependencies: looking for libncurses.so.4
D: dependencies: looking for libpam.so.0
D: dependencies: looking for libpam_misc.so.0
D: dependencies: looking for libslang.so.0
D: dependencies: looking for libtermcap.so.2
D: installing binary packages
Installing util-linux-2.8-11.i386.rpm
D: New Header signature
D: Signature size: 236
D: Signature pad : 4
D: sigsize         : 240
D: Header + Archive: 310635
D: expected size   : 310635
D: package: util-linux-2.8-11 files test = 0
D: running preinstall script (if any)
unpacking of archive failed on file /bin/login: cpio: unlink failed -
Operation not permitted
error: util-linux-2.8-11.i386.rpm cannot be
installed


------- Additional Comments From   03/18/99 04:54 -------
I tried another approach:

# rpm2cpio ~/temp/util-linux-2.8-11.i386.rpm | cpio
-i --unconditional
cpio: cannot remove current bin/login: Operation not permitted
1537 blocks

This indicates to me that this is not an rpm problem, but something
that in general prevents me from modifying /bin/login. The permissions
for /bin/ login are (still)

-rws--x--x   1 root     root       252040 Oct 23  1997 /bin/login

The size is way too large. If I unpack bin/login to another directory,
the size is only 15284 bytes. The permissions are the same. I have
also tried to remove /bin/login manually, this gives

# rm -v login
removing login
rm: cannot unlink `login': Operation not permitted

Running fsck un the unmounted /dev/hda2 (where the root filesystem
resides) did not help.

Is it possible that my system has been hacked, and the login program
changed to capture my passwords?
Comment 4 sjw 1999-03-18 14:01:59 EST
That file is way too large. Looks like a hack is a possiblity you may
want to consider. But, there might just be some kind of system
problem. Reboot using a boot disk, mount up the drive, and try to
remove it there. If it still won't remove, it's a disk problem.

Also, be sure to put another copy of login back in there before you
reboot again. Or you may not be too happy. :-)

------- Additional Comments From   03/19/99 03:49 -------
I already tried booting from a boot disk, mounting and rm'ing (cf. the
original bug report), so that's not it. So it is a system problem?
Comment 5 Jeff Johnson 1999-03-24 19:16:59 EST
Boot to single user amd delete the file.
You might also look at chattr(1) which may be
what is preventing you from removing/chaanging the file.

This is not a util-linux problem.

------- Additional Comments From   04/07/99 07:22 -------
I have booted to single user mode before; that dit not help. However,
lsattr showed that /bin/login had the "a" attribute set. I have no
idea why. Anyway, using chattr I removed this attribute and deleted
(or rather, moved for future reference) /bin/login. After that, I
could install util-linux without problems. In other words, the problem
was my lack of knowledge about these 'hidden' attributes.

Note You need to log in before you can comment on or make changes to this bug.