Bug 132603 - need fence info output to syslog
need fence info output to syslog
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: David Teigland
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 19:04 EDT by Corey Marthaler
Modified: 2010-01-11 21:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 17:33:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2004-09-14 19:04:50 EDT
Description of problem: 
When a node is fenced there is nothing reported in the syslog by the 
fencer. The only way I know who's fencing who is because I added 
debugging info to fence_apc. In 6.0 and 5.2.1 there were messages 
stating who was about to be fenced and then weither or not it was 
successful. The only way to know what's happening now is to run 
fenced with the debugging flag and in the foreground. 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. attempt recovery senario
Comment 1 David Teigland 2004-09-17 00:09:54 EDT
How does this look?

RCS file: /cvs/cluster/cluster/fence/fenced/recover.c,v
retrieving revision 1.2
diff -r1.2 recover.c
181a182
>               syslog(LOG_INFO, "fencing node \"%s\"", node->name);
187a189,191
> 
>               syslog(LOG_INFO, "fence \"%s\" %s", node->name,
>                      error ? "failed" : "success");
Comment 2 Corey Marthaler 2004-09-17 14:53:35 EDT
looks good.  
 
fix verified. 
Comment 3 Derek Anderson 2004-09-22 15:21:32 EDT
This is good, but it is also necessary for troubleshooting to have the
output of the fence agent in here, as it was for 6.0.0.  I'm currently
in a state where a log is reporting:

Sep 22 14:23:32 tng3-1 fenced[2267]: fencing node "tng3-3"
Sep 22 14:23:32 tng3-1 fenced[2267]: fence "tng3-3" failed

over and over again with no additional info on what's gone wrong.
Comment 4 David Teigland 2004-09-23 03:04:43 EDT
With today's checkin it worked with my test.
Comment 5 Corey Marthaler 2004-09-27 17:33:07 EDT
the output of the fence agent does now appear. fix verified.
Comment 6 Kiersten (Kerri) Anderson 2004-11-16 14:04:47 EST
Updating version to the right level in the defects.  Sorry for the storm.

Note You need to log in before you can comment on or make changes to this bug.