Bug 1326047 - Network Manager IPv4 and IPv6 dialogs incorrectly displayed, unusable with mouse
Summary: Network Manager IPv4 and IPv6 dialogs incorrectly displayed, unusable with mouse
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker https://fedoraproject...
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-04-11 16:08 UTC by Sumit Bhardwaj
Modified: 2016-05-06 13:12 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-18 16:27:51 UTC


Attachments (Terms of Use)
Screenshot showing the improperly sized Network manager dialogs (701.09 KB, image/png)
2016-04-11 16:08 UTC, Sumit Bhardwaj
no flags Details

Description Sumit Bhardwaj 2016-04-11 16:08:06 UTC
Created attachment 1146043 [details]
Screenshot showing the improperly sized Network manager dialogs

Description of problem:

The network properties dialog of network manager in Gnome, that displays configuration of an existing network while editing a connection ( or its profile) or allows to enter configuration while creating new connection has a display issue with controls on IPv4 and IPv6 configuration screens. The controls are not placed properly and the dialog is not sized correctly. It is not possible to click on the buttons with mouse, although it works with TAB key on keyboard. The problem occurs for all types of connections.

A screenshot of the problem is attached.

Version-Release number of selected component (if applicable):
1.2.0-0.8 rc1

How reproducible:
Everytime opening the settings dialog of any connection in Network dialog inside settings.


Steps to Reproduce:
1. Open Settings > Network.
2. Try to configure a network connection by clicking the gear icon against its name.
3. Click on IPv4 and/or IPv6 settings page.

Actual results:
The dialog is improperly size, controls are placed haphazardly and some of the controls are not clickable. 

Expected results:
Tha dialog should display properly sized, with controls properly laid out and clickable.

Additional info:

Comment 1 Fedora Blocker Bugs Application 2016-04-11 16:10:32 UTC
Proposed as a Blocker for 24-beta by Fedora user krazyabouttechnology using the blocker tracking app because:

 The Network Manager dialogs are part of core experience of Fedora Workstation. For an average user, this makes it difficult to change network settings and makes the product looks unpolished and unfinished.

Comment 2 Stephen Gallagher 2016-04-11 16:44:13 UTC
Are you running on a Wayland session or an X11 session?

I can reproduce the issue on Wayland right now, but I haven't tried under X11.

I'm +1 Final Blocker if this is reproducible on X11 under the criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

I don't think this violates any strict Beta or Alpha criteria, but it's certainly unpleasant.

Comment 3 Kamil Páral 2016-04-11 17:08:57 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Final) - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test." The 'advanced network config' experience for Beta is unfortunate, but we don't consider it a sufficiently serious case to take as a conditional violation of e.g. updates criterion

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-04-11/

Comment 4 Stephen Gallagher 2016-04-11 17:20:13 UTC
Also from the blocker review meeting, several individuals also confirmed that it's an issue on X11 as well.

I'd like to add that while it's not a Beta *blocker*, it's extremely bad behavior and it would be mightily appreciated if it could be fixed in time for Beta release (since it will be visible on the Workstation Live media).

Comment 5 Sumit Bhardwaj 2016-04-11 17:26:37 UTC
While testing I was on a X11 session so it happens on both wayland and X11.

Comment 6 Lubomir Rintel 2016-04-15 19:07:47 UTC
Thanks for the report. This is a gtk+ issue, tracked upstream here: https://bugzilla.gnome.org/show_bug.cgi?id=764174
Will hit Fedora with GNOME 3.20.1 update hopefully

Comment 7 Matthias Clasen 2016-04-18 16:27:51 UTC
fixed in gtk3 3.20.3


Note You need to log in before you can comment on or make changes to this bug.