Bug 1326062 - [RH Ceph 2.0 - 10.1.1] test/librados/watch_notify.cc:309: Failure LibRadosWatchNotify.Watch2Timeout
Summary: [RH Ceph 2.0 - 10.1.1] test/librados/watch_notify.cc:309: Failure LibRadosWat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Samuel Just
QA Contact: Vasu Kulkarni
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-11 17:04 UTC by Vasu Kulkarni
Modified: 2017-07-30 15:14 UTC (History)
5 users (show)

Fixed In Version: ceph-10.2.0-1.el7cp
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:35:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 15441 None None None 2016-04-13 21:52:49 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Vasu Kulkarni 2016-04-11 17:04:47 UTC
Description of problem:
rados test fails with random ms fails following test
test/librados/watch_notify.cc:309: Failure LibRadosWatchNotify.Watch2Timeout

Version-Release number of selected component (if applicable):
ceph version 10.1.1-1.el7cp (61adb020219fbad4508050b5f0a792246ba74dae)

How reproducible:
1/1

Steps to Reproduce:
rados/test.sh with random ms

Actual results:

2016-04-09T23:35:23.140 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: [ RUN      ] LibRadosWatchNotify.AioWatchDelete
2016-04-09T23:35:23.141 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: waiting up to 300 for disconnect notification ...
2016-04-09T23:35:23.142 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: watch_notify2_test_errcb cookie 140434457569840 err -107
2016-04-09T23:35:23.143 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: [       OK ] LibRadosWatchNotify.AioWatchDelete (1021 ms)
2016-04-09T23:35:23.144 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: [ RUN      ] LibRadosWatchNotify.Watch2Timeout
2016-04-09T23:35:23.145 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: waiting up to 900 for osd to time us out ...
2016-04-09T23:35:23.146 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: test/librados/watch_notify.cc:309: Failure
2016-04-09T23:35:23.148 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: Value of: left > 0
2016-04-09T23:35:23.149 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify:   Actual: false
2016-04-09T23:35:23.150 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: Expected: true
2016-04-09T23:35:23.151 INFO:tasks.workunit.client.0.clara004.stdout:         api_watch_notify: [  FAILED  ] LibRadosWatchNotify.Watch2Timeout (899114 ms)

Expected results:


Additional info:

http://magna002.ceph.redhat.com/vasu-2016-04-09_11:26:14-rados:monthrash-jewel---basic-clara/217843/teuthology.log

Comment 2 Samuel Just 2016-04-13 21:52:49 UTC
Sage has a PR

Comment 3 Ken Dreyer (Red Hat) 2016-04-22 16:35:09 UTC
Looks like this was fixed upstream in v10.2.0.

Comment 5 Samuel Just 2016-05-09 20:31:20 UTC
Pending backport to hammer.

Comment 6 Samuel Just 2016-05-09 20:46:45 UTC
Oops, I changed the wrong one.  This is in 10.2.0, so I marked it POST?

Comment 7 Samuel Just 2016-05-09 21:02:28 UTC
It's in 10.2.0, so it's MODIFIED I guess

Comment 10 Vasu Kulkarni 2016-06-21 23:51:19 UTC
Verified in regression run.

Comment 12 errata-xmlrpc 2016-08-23 19:35:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.