Bug 1326095 - repoquery --whatsupplements doesn't work for langpacks (rich capability issue)?
Summary: repoquery --whatsupplements doesn't work for langpacks (rich capability issue)?
Status: CLOSED DUPLICATE of bug 1303311
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 24
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-11 19:49 UTC by Adam Williamson
Modified: 2016-04-12 03:28 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-04-12 03:13:50 UTC


Attachments (Terms of Use)

Description Adam Williamson 2016-04-11 19:49:08 UTC
Per https://fedoraproject.org/wiki/QA:Testcase_langpacks_packages it's expected that `dnf repoquery --whatsupplements langpacks-fr` would return a list - e.g. including glibc-langpack-fr - but it returns nothing.

I suspect this may be because glibc-langpack-fr really supplements a rich capability:

glibc = 2.23.1-5.fc24 & (langpacks-fr | langpacks-fr_BE | langpacks-fr_CA | langpacks-fr_CH | langpacks-fr_FR | langpacks-fr_LU)

but obviously it's not realistic that someone would somehow know to type:

dnf repoquery --whatsupplements "glibc = 2.23.1-5.fc24 & (langpacks-fr | langpacks-fr_BE | langpacks-fr_CA | langpacks-fr_CH | langpacks-fr_FR | langpacks-fr_LU)"

and more to the point, even that doesn't work. So it seems like this is kind of un-queryable, or I missed the magic trick.

Is this fixable? If not, is there any way to provide the `dnf langinfo` feature of the old langpacks plugin?

Comment 1 Parag Nemade 2016-04-12 03:13:50 UTC
Thanks Adam for this bug but we already are tracking this issue in bug 1303311. Since we moved to weak dependencies approach to install langpacks, I created test case page on how to test it.

Ah wait what happened to my test case page. Ah you moved it and re-written!!

Okay no issues but I explicitly left the output blank as I am discussing this issue with DNF developers.

*** This bug has been marked as a duplicate of bug 1303311 ***

Comment 2 Adam Williamson 2016-04-12 03:26:13 UTC
well, i'd say the test could still say what *ought* to happen =) I can tweak it to note that that part is currently known broken, though, to avoid duplicate reports.

Comment 3 Parag Nemade 2016-04-12 03:28:29 UTC
Looks like its fixed now see comment  https://bugzilla.redhat.com/show_bug.cgi?id=1303311#c12


Note You need to log in before you can comment on or make changes to this bug.