Bug 132613 - System shuts down on ACPI S3 resume with 2.6.8-1.541
System shuts down on ACPI S3 resume with 2.6.8-1.541
Status: CLOSED DUPLICATE of bug 118353
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 01:51 EDT by Stefan Rotsch
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Rotsch 2004-09-15 01:51:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
When resuming from ACPI S3 on my ThinkPad R32, the system shuts down
immediately. I have to press the power button to make the system
resume. acpid catches the pressed button and shuts down the system:

--- /var/log/acpid running Kernel 2.6.8-1.541
[Wed Sep 15 07:10:08 2004] END HANDLER MESSAGES
[Wed Sep 15 07:10:08 2004] action exited with status 0
[Wed Sep 15 07:10:08 2004] completed event "button/sleep SLPB 00000080
00000001"
[Wed Sep 15 07:10:08 2004] received event "button/power PWRF 00000080
00000001"
[Wed Sep 15 07:10:08 2004] notifying client 3721[500:500]
[Wed Sep 15 07:10:08 2004] executing action "/sbin/shutdown -h now"
[Wed Sep 15 07:10:09 2004] BEGIN HANDLER MESSAGES
[Wed Sep 15 07:10:15 2004] END HANDLER MESSAGES
[Wed Sep 15 07:10:15 2004] action exited with status 0
[Wed Sep 15 07:10:15 2004] completed event "button/power PWRF 00000080
00000001"
[Wed Sep 15 07:10:24 2004] exiting

This doesn't happen with Kernel 2.6.8-1.526 (I missed some updated
Kernels, so I can't say exactly when things got broken):

--- /var/log/acpid running Kernel 2.6.8-1.526 ---
[Wed Sep 15 07:25:05 2004] END HANDLER MESSAGES
[Wed Sep 15 07:25:05 2004] action exited with status 0
[Wed Sep 15 07:25:05 2004] completed event "button/sleep SLPB 00000080
00000001"


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1. Boot into kernel 2.6.8-1.541
2. Enter ACPI S3: echo "mem" > /sys/power/state
3. Resume by hitting the power button (on IBM ThinkPads)
    

Actual Results:  System receives a shutdown request and shuts down
immediately after resuming from S3.

Expected Results:  System should simply resume (like it did with other
kernels before 2.6.8-1.541).

Additional info:

There's a similar bug open:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118353

but there has been no activity on it since May. This is why I opened a
new bug. Also things worked fine for me before 2.6.8-1.541.
Comment 1 Bill Nottingham 2004-09-15 17:00:17 EDT

*** This bug has been marked as a duplicate of 118353 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.