Bug 1326131 - calamari-ctl initialize requiring salt-minion to work
Summary: calamari-ctl initialize requiring salt-minion to work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: Harish NV Rao
URL:
Whiteboard:
: 1324494 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-11 22:29 UTC by Christina Meno
Modified: 2016-08-23 19:35 UTC (History)
3 users (show)

Fixed In Version: calamari-server-1.4.0-rc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:35:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Christina Meno 2016-04-11 22:29:12 UTC
Description of problem:
the spec file dropped package all requirements on salt, but initialize still uses the salt-call command which requires salt-minion and salt-common.

There are two fixes possible:
1. re depend on salt-minion and salt-common
2. re-write calamari-ctl to execute without salt

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. install calamari without bootstrapping Storage Console
2. run calamari-ctl intialize
3. observe error

Actual results:
calamari-ctl errors

Expected results:
calamari-ctl does not error

Additional info:

Comment 2 Christina Meno 2016-04-27 15:39:24 UTC
*** Bug 1324494 has been marked as a duplicate of this bug. ***

Comment 4 Harish NV Rao 2016-06-09 11:57:09 UTC
The 'calamari-ctl initialize' is running successfully without any errors in recent builds. Moving this to verified.

[ubuntu@magna070 ~]$ sudo  calamari-ctl initialize 
[INFO] Loading configuration..
[INFO] Starting/enabling postgres...
[INFO] Updating database...
[ubuntu@magna070 ~]$

Comment 6 errata-xmlrpc 2016-08-23 19:35:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.