Bug 132619 - agpgart.o cannot be loaded on kernel-2.4.21-20.EL from U3
Summary: agpgart.o cannot be loaded on kernel-2.4.21-20.EL from U3
Status: CLOSED DUPLICATE of bug 131907
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-15 07:35 UTC by Stephen Bala
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Bala 2004-09-15 07:35:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
After upgrading to the latest RPM I can no longer start xfree86. I get
an error message that states 
 
GARTInit: Unable to open /dev/agpgart (No such device) 
I810(0): AGP GART support is not available. Make sure your kernel has
agpgart support or that the agpgart kernel module is loaded. 
Screen(s) found, but none have a usable configuration 
 
As a side note, I moved the agpgart.o from a previous release of the
kernel (2.4.21-15.0.4.EL to 2.4.21-20.EL and xfree86 WILL THEN START.
the agpgart.o modules did reside in the
lib/modules/2.4.21-20.EL/kernel/drivers/char/agp but would not load.
If I tried to manually load with insmod I get an error No such device.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Didn't try


Additional info:

Comment 1 Kostas Georgiou 2004-09-24 13:16:10 UTC
Stephen have a look at bug# 131907

Comment 2 Suzanne Hillman 2004-09-27 20:26:35 UTC

*** This bug has been marked as a duplicate of 131907 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:05:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.