Bug 1326212 - gluster volume heal info shows conservative merge entries as in split-brain
Summary: gluster volume heal info shows conservative merge entries as in split-brain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1319406 1322253
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-12 07:34 UTC by Pranith Kumar K
Modified: 2016-06-28 12:14 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1322253
Environment:
Last Closed: 2016-06-28 12:14:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-12 07:36:08 UTC
REVIEW: http://review.gluster.org/13975 (cluster/afr: Fix witness counting code in src/sink detection) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-04-13 01:52:21 UTC
REVIEW: http://review.gluster.org/13975 (cluster/afr: Fix witness counting code in src/sink detection) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Vijay Bellur 2016-04-17 01:56:00 UTC
COMMIT: http://review.gluster.org/13975 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 07ea879362348d6c355b7ea7c197e3e80ec25485
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Mar 21 23:26:43 2016 +0530

    cluster/afr: Fix witness counting code in src/sink detection
    
    Problem:
    In afr-v1 pre-op, xattrop increments self xattr first then it increments the
    value on rest. In post-op, xattr value is decreased first on rest and at last
    it gets decremented on self. So for a possible operation to be witnessed i.e.
    a fop is seen by the brick it is important to have at least 1 pending op
    because without completing pre-op fop won't come. The other possibility is when
    fop completes but at the time of post-op after decrementing pending counts on
    others just before decrementing its own pending count, the brick dies.
    
    Fix:
    Fix witness detection code in afr_self_heal_find_direction()
    
     >BUG: 1322253
     >Change-Id: Ia7e76482c0a46e775e269bb96ec1b9490a3ac18f
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/13811
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
     >(cherry picked from commit e88962f8c49ea1d65fa26703e5c11be3f21af2ba)
    
    Change-Id: I5d9a6d323b35409127c26f3ce61c5e1d91395b18
    BUG: 1326212
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13975
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Kaushal 2016-06-28 12:14:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.