Bug 132626 - keep alive HTTP and FTP connection
keep alive HTTP and FTP connection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
FC4
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 05:06 EDT by Karel Zak
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 21:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2004-09-15 05:06:18 EDT
Description of problem:

Anaconda should be keep and reuse FTP connection and doesn't connect
always again for each package to ftp server. The same problem is with
HTTP where is possible use keep-alive header and reuse one connection
for more packages loading. For details see urlinstall.py in anaconda
sources.

It's important, because make new connection is pretty slow and if
server is paraniod (does some checks - DNS, auth, ...) the FC
instalation can takes 3 hours.

I think the current urllib2 usage is too primitive. For HTTP
keeps-alive implementation with urllib2 see in the yum's sources
file urlgrabber/keepalive.py.

For FTP you can use directly ftplib python module instead urllib2.

Expected results:

Don't spend all day with FC installation by FTP/HTTP although between
your computer and server is 2GB network...
Comment 1 Jeremy Katz 2004-09-15 14:45:24 EDT
The plan is to move to using urlgrabber eventually.  There's
unfortunately not a good "quick fix" that doesn't involve fairly
invasive changes.
Comment 2 Karel Zak 2004-09-16 03:03:40 EDT
Ok. Is urlgrabber usable for good work (=reure connections) with FTP?
I think it solve HTTP usage only. But I'm unsure :-)
Comment 3 Chris Lumens 2005-02-07 16:17:02 EST
urlgrabber appears to only have support for HTTP connection reuse.  The good
news is that moving to urlgrabber not only gets us HTTP keepalive support fairly
easily, but if someone adds FTP connection reuse, we can make use of that.  Will
look into it / talk to upstream.
Comment 4 Jeremy Katz 2005-04-16 21:50:22 EDT
We do HTTP now.  Not going to explicitly add FTP keepalive -- file an RFE
against urlgrabber (preferably upstream) if you feel the support is that important.

Note You need to log in before you can comment on or make changes to this bug.