Bug 1326544 - Should add qxl mode to video when display is vnc in virt-manager
Summary: Should add qxl mode to video when display is vnc in virt-manager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-13 02:29 UTC by mxie@redhat.com
Modified: 2016-11-04 02:01 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.4.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:01:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description mxie@redhat.com 2016-04-13 02:29:32 UTC
Description of problem:
Should add qxl mode to video when display is vnc in virt-manager

Version-Release number of selected component (if applicable):
virt-manager-1.3.2-1.el7.noarch


How reproducible:
100%

Steps to Reproduce:
1.Open virt-manager and prepare a poweroff guest in the virt-manager
2.Double click the guest,open guest's virtual hardware details,and then change the display to VNC 
3.Find qxl is not listed in video mode
4.But vnc+qxl mode is supported,pls refer to bug: https://bugzilla.redhat.com/show_bug.cgi?id=1312254#c5


Actual results:
As above description

Expected results:
Should add qxl mode to video when display is vnc in virt-manager


Addtional info:

Comment 2 Pavel Hrdina 2016-05-20 16:23:47 UTC
Upstream commit:

commit 4506d49ff55eea9649f02db5c9449084add2dc4d
Author: Pavel Hrdina <phrdina>
Date:   Fri May 20 17:51:02 2016 +0200

    addhardware: don't remove QXL if VNC graphics are configured
    
    Commit 1a6e803a introduced a fix for bogus behavior of QXL+VNC where
    there was no cursor visible by disabling this configuration in
    virt-manager.  We should enable it again because this is a supported
    configuration and the bug was actually in QEMU.
    
    This is now fixed in qemu-2.6.0 [1] so revert commits 1a6e803a and
    67ca0a9f.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1326544
    
    [1] http://lists.nongnu.org/archive/html/qemu-devel/2016-03/msg00507.html

Comment 4 zhoujunqin 2016-07-19 10:31:03 UTC
I can reproduce this issue with package
virt-manager-1.3.2-1.el7.noarch

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch
libvirt-2.0.0-2.el7.x86_64
qemu-kvm-rhev-2.6.0-14.el7.x86_64
libvirt-python-2.0.0-1.el7.x86_64

Steps:
1. Prepare a health guest with
Display: vnc
Video: cirrus

2. Scenario-1 change video model to QXL

2.1 Launch virt-manager, and try to change video to other mode: QXL
# virt-manager
Select virtual machine 'rhel6.8latest'--->Open--->'Show virtual machine details'--->change video model from 'cirrus' to 'qxl'

Result: 'QXL' is displayed in video model and can be selected.
        Virtual machine with vnc+qxl can boot up with no error.

3. Scenario-2 add video model QXL

3.1 Shut off guest and restore its configuration to vnc+cirrus.

In 'Show virtual machine details' page, add new Video to virtual machine.

Result: QXL video model is showed and can be add as second video to virtual    machine when display is vnc.
        Virtual machine with vnc+cirrus+qxl can boot up with no error.
        
Since QXL is added to video model when display is vnc in virt-manager, move this bug from ON_QA to VERIFIED.

Comment 6 errata-xmlrpc 2016-11-04 02:01:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.