Bug 1326549 - RFE: Make the "openstack overcloud node delete" a foreground process
Summary: RFE: Make the "openstack overcloud node delete" a foreground process
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Brad P. Crochet
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-13 03:27 UTC by Dan Macpherson
Modified: 2017-05-17 19:29 UTC (History)
18 users (show)

Fixed In Version: openstack-tripleo-common-5.7.1-0.20170126235054.c75d3c6.el7ost
Doc Type: Bug Fix
Doc Text:
When deleting a node in heat, the deletion command finished and the prompt returned, although the process was still going on in the background. If another command followed immediately, a conflict would occur and the consequent command would fail. The behavior of the process has been changed. Now, the prompt will only return, when the process finishes completely.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:29:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 407740 None None None 2017-01-03 09:02:25 UTC
OpenStack gerrit 407741 None None None 2016-12-21 12:44:57 UTC
Launchpad 1640770 None None None 2016-12-21 12:44:11 UTC

Description Dan Macpherson 2016-04-13 03:27:31 UTC
Description of problem:
When you run "openstack overcloud node delete" it starts a stack update in Heat in the background then drops to the CLI. This could cause stack update collisions if you run another overcloud command immediately after. For example, run "openstack overcloud node delete" then run "openstack overcloud deploy" immediately after. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run "openstack overcloud node delete" and wait to be dropped to the command line
2. Run "openstack overcloud deploy" immediately after
3. Wait for a bit,then run "heat stack-list --show-nested" to see stack with status of "UPDATE_FAILED"

Actual results:
Stack update collisions

Expected results:
Maybe the same behavior as "openstack overcloud deploy" i.e. don't drop the the CLI, but instead show a log of the processes occurring.

Additional info:
I've documented where applicable to wait until the "openstack overcloud node delete" completes, but this might be a good RFE as a safety feature.

Comment 3 rlopez 2016-07-15 16:26:33 UTC
+1 It's odd when all the other cmds don't drop back into the cmd line until operation is complete.

Comment 4 Julie Pichon 2016-12-21 12:44:12 UTC
There seems to already be work on-going to resolve this upstream. I'm updating the bug to match that information and will help with reviews as I can upstream. Brad, please let me know if this isn't ok or it turns out I misunderstood something. Thank you!

Comment 7 Julie Pichon 2017-01-05 15:07:08 UTC
Patches merged upstream.

Comment 8 Julie Pichon 2017-02-08 13:44:42 UTC
Checking the current puddle, the fix seems to be present. Updating NVR (hopefully correctly!) and component.

Comment 13 Udi 2017-04-27 13:52:36 UTC
Verified. Deleted a compute node and saw that the workflow env was updated with the new counter.

Comment 14 errata-xmlrpc 2017-05-17 19:29:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.