Bug 132673 - FC2 Anaconda loses login info for FTP install while looking for updates.img
FC2 Anaconda loses login info for FTP install while looking for updates.img
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 14:50 EDT by Judd Taylor
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:39:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Judd Taylor 2004-09-15 14:50:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:

I'm doing a PXE/FTP install on my cluster, and I get an error mesage
saying:

Failed to log into 192.168.1.206:
Failed to connect to FTP server

And on Ctrl-Alt-F3:
transferring
ftp://192.168.1.206//data3/fc2/i386/Fedora/base/updates.img to a fd

The kickstart file lists the source as FTP with a login/password:
url --url ftp://s4p_node:HIDDENPASS@192.168.1.206/data3/fc2/i386

It appears that when anaconda looks for the existance of the
updates.img file using the FTP URL from the kickstart file, it strips
off the login account and password.

I don't really care that it can't find that file, but it propts for an
"OK" after the error message, which ruins my
unattended/non-interactive install.

So I have 2 requests:
1. fix the login info in that portion of the install
2. make this a "silent" error (or at least non-interactive), since
it's just checking for the existance of a file anyways...

Thanks,
Judd Taylor


Version-Release number of selected component (if applicable):
whatever is on the install disk...

How reproducible:
Always

Steps to Reproduce:
1. Setup a kickstart install over FTP that requires a login/pass
2. See the error on main screen and ctrl-alt-f3
3.
    

Actual Results:  See above

Expected Results:  See above

Additional info:
Comment 1 Jeremy Katz 2004-09-15 15:12:49 EDT
Made a silent error like the rest of the errors there (one case wasn't
in an if !silentErrors)
Comment 2 Judd Taylor 2004-09-15 17:25:06 EDT
I figured out how to fix issue #1 (yeehaw!)

The problem is in loader2/urls.c, where urlinstStartTransfer() passes
ui->password to ftpOpen(). IT passes the password only, when the
required format by ftpOpen() is the password with a '@' char appended.
The solution would be to modify urls.c to create a buffer in which it
can add a '@' char to the end of the ui->password and send that to
ftpOpen() instead of ui->password directly.

I haven't tested the modified version yet, but I'll let you know if it
worked as soon as I do.

-Judd

PS: I'm not sure what you mean by !silentErrors, what should I change
to get rid of the dialog box?
Comment 3 Judd Taylor 2004-09-16 16:36:40 EDT
After running a bunch of tests, the above fix didn't work. I don't
know why. 

I think this is a more architectural issue anyways. Why should
ftpOpen() expext a different format of the password than what's stored
in the ui struct? To fix that, you'd have to make sure that the other
calls to ftpOpen() use a plain password (without the '@' on the end)
throughout the code... which probably won't be much fun.

-Judd
Comment 4 Rahul Sundaram 2005-08-15 12:30:20 EDT
ping

Note You need to log in before you can comment on or make changes to this bug.