Bug 1326815 - Capsule sync failed while syncing docker contents: [E] DKR1008: Could not find registry API at <http://sat_server>:5000 (Katello::Errors::PulpError)
Summary: Capsule sync failed while syncing docker contents: [E] DKR1008: Could not fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-13 13:08 UTC by Sachin Ghai
Modified: 2019-09-26 17:34 UTC (History)
2 users (show)

Fixed In Version: rubygem-katello-3.0.0.19-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:31:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14647 None None None 2016-04-22 16:05:51 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Sachin Ghai 2016-04-13 13:08:45 UTC
Description of problem:
I Installed sat6.2 snap7.1 and synced docker contents and published/promoted to 'dev' env via CV. However when I ran capsule sync, sync failed with error:

[root@cloud-qe-3 ~]# hammer -u admin -p changeme capsule content synchronize --id=2
[............................................................................................................................................] [100%]
OST0004: Feed URL not specified
DKR1008: Could not find registry API at https://cloud-qe-3.idmqe.lab.eng.bos.redhat.com:5000


for "OST0004: Feed URL not specified" separate bz is filed:  https://bugzilla.redhat.com/show_bug.cgi?id=1323644




 2016-04-13 07:14:55 [foreman-tasks/action] [E] DKR1008: Could not find registry API at https://cloud-qe-3.idmqe.lab.eng.bos.redhat.com:5000 (Katello::Errors::PulpError)
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.15/app/lib/actions/pulp/abstract_async_task.rb:121:in `block in external_task='
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.15/app/lib/actions/pulp/abstract_async_task.rb:119:in `each'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.15/app/lib/actions/pulp/abstract_async_task.rb:119:in `external_task='
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/action/polling.rb:98:in `poll_external_task_with_rescue'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/action/polling.rb:21:in `run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/action/cancellable.rb:9:in `run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.15/app/lib/actions/pulp/abstract_async_task.rb:45:in `run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/action.rb:506:in `block (3 levels) in execute_run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/middleware/stack.rb:26:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/middleware.rb:17:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/middleware.rb:30:in `run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.10/lib/dynflow/middleware/stack.rb:22:in `call'
 

Version-Release number of selected component (if applicable):
Sat6.2 snap7.1

How reproducible:
always

Steps to Reproduce:
1. sync docker contents like I synced centos image
2. promoted to another env via CV
3. synced the contents to capsule

Actual results:
capsule sync failed with: DKR1008: Could not find registry API at https://cloud-qe-3.idmqe.lab.eng.bos.redhat.com:5000


Expected results:
sync should work

Additional info:

Comment 2 John Mitsch 2016-04-14 15:33:51 UTC
Created redmine issue http://projects.theforeman.org/issues/14647 from this bug

Comment 3 Bryan Kearney 2016-04-14 20:12:01 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14647 has been closed
-------------
John Mitsch
Applied in changeset commit:katello|ed733b49c8e0e53a9f77d35c658350170434e8e0.

Comment 6 Sachin Ghai 2016-04-21 11:13:52 UTC
Verified sat6.2 beta snap9.

I can sync docker contents to isolated capsule. I synced a centos repos from docker.io and published in a CV. Please see the sync status.

[root@cloud-qe-17 sat62]# hammer -u admin -p changeme capsule content synchronize --id=2
[............................................................................................................................................] [100%]



[root@cloud-qe-14 app]# ll
total 4
lrwxrwxrwx. 1 apache apache 155 Apr 21 07:02 default_organization-dev-cv_rhel7-docker-centos.json -> /var/lib/pulp/published/docker/v2/master/default_organization-dev-cv_rhel7-docker-centos/1461236521.58/default_organization-dev-cv_rhel7-docker-centos.json
[root@cloud-qe-14 app]# 


 app]# ll
total 4
lrwxrwxrwx. 1 apache apache 155 Apr 21 07:02 default_organization-dev-cv_rhel7-docker-centos.json -> /var/lib/pulp/published/docker/v1/master/default_organization-dev-cv_rhel7-docker-centos/1461236521.58/default_organization-dev-cv_rhel7-docker-centos.json

Comment 8 errata-xmlrpc 2016-07-27 09:31:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.