Bug 1326852 - Incremental repo import from exported CV contents is not updating the packages nor throwing any error.
Summary: Incremental repo import from exported CV contents is not updating the package...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Chris Duryee
QA Contact: Jitendra Yejare
URL:
Whiteboard:
: 1332616 (view as bug list)
Depends On: 1314299
Blocks: 1332616
TreeView+ depends on / blocked
 
Reported: 2016-04-13 14:33 UTC by Jitendra Yejare
Modified: 2019-09-25 21:29 UTC (History)
12 users (show)

Fixed In Version: pulp-rpm-2.8.3.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1332616 (view as bug list)
Environment:
Last Closed: 2016-07-27 11:26:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 1543 Normal CLOSED - CURRENTRELEASE As a user, I would like incremental export to be the same format as full export 2016-07-12 20:31:34 UTC
Foreman Issue Tracker 14915 None None None 2016-05-23 14:46:29 UTC

Description Jitendra Yejare 2016-04-13 14:33:16 UTC
Description of problem:
Incremental import is not updating packages from incremental exported CV contents.

Version-Release number of selected component (if applicable):
Satellite 6.2 Snap 7.1

How reproducible:
Always

Steps to Reproduce:
Pre-requisite:
1. Export whole CV version having mixed(redhat and custom) repos to a directory
specified in settings.
2. Explore exported contents to /var/www/html/pub/export directory.
3. Set the step 2 location path as CDN URL for redhat repo to import
the exported CV redhat repo.
4. Also set full custom repo path from step 2 location by creating new
custom repo to import custom repo contents.
5. Sync both redhat and custom repos in imported org/satellite.

For incremental Export and Import:
6. Add some packages to both repos added in earlier exported CV.
7. Publish/promote a new cv version.
8. Export new version incrementally from last exported(step1) date.
9. Explore newly exported versions content to /var/www/html/pub/export/
10. Incrementally import both custom and redhat repos contents from
step 9 location.

Actual results:
1. The number of packages are not updated even after successful(100%) completion of incremental import.
2. No error thrown for not updating packages on incremental import of repo.

Expected results:
1. The number of packages should be updated after successful(100%) completion of incremental import.
2. Error causing package updates on incremental import should be thrown in bg.

Additional info:

Comment 2 Mike McCune 2016-04-14 17:56:50 UTC
moving to GA target, the work required to finish this is too much to get done before beta goes out.

Users will need to only use full exports for Beta and use incremental after GA.

Comment 3 Chris Duryee 2016-04-14 18:06:31 UTC
To give more detail, the current incremental import is slow and causes a number of strange issues. I can rewrite the incremental export so that it's in the same format as the full export. This avoids needing special code for incremental import and should speed it up significantly. It will also allow use of http for incremental import.

Comment 4 Jitendra Yejare 2016-04-19 12:45:01 UTC
This issue is also reproducible in case of exported as ISO and imported from this ISO contents. So need to look into this as well.

Comment 5 Chris Duryee 2016-04-21 15:02:27 UTC
BETA WORKAROUND NOTE:

There are a handful of bugs related to incremental import of repositories which are being addressed for GA. I believe the workaround for this bug is to ensure the exported incremental repo has a small (less than 100) number of packages.

The incremental export/import mechanism is being reworked for GA, which will resolve these bugs.

Comment 6 Bryan Kearney 2016-05-03 16:18:39 UTC
Upstream bug component is Content Management

Comment 9 Chris Duryee 2016-05-23 14:47:15 UTC
*** Bug 1332616 has been marked as a duplicate of this bug. ***

Comment 11 pulp-infra@redhat.com 2016-05-23 15:00:57 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 12 pulp-infra@redhat.com 2016-05-23 15:01:00 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 13 Jitendra Yejare 2016-06-07 09:49:20 UTC
@Chris,

Please update the steps changed for incremental import of cv in GA to repro this issue.

Thanks,
Jitendra

Comment 14 Chris Duryee 2016-06-07 15:14:24 UTC
It should work the same from a user perspective. You should be able to still use "file:///" if you want, but "http" will also work now.

Note though that for CV export, the incremental will only work as expected if you are exporting the Default Organization View (typically this is CV with id #1). If you use a published CV version, there is no incremental change to update. For example, if you publish version #1 of a CV, then version #2, the #2 CVV will have an entirely new set of repos, so there's no incremental change in #2.

Comment 17 Jitendra Yejare 2016-06-29 12:28:35 UTC
Verified !

@ Sat 6.2 GA Snap 17

Steps Followed:
1. Exported full RH and custom repo and imported full
2. Added some RPM's to both repos.
3. Incrementally export and imported the repos with newly updated rpms.


Result:

# hammer repository synchronize --id 1 --incremental 1 --source-url http://qeblade36.rhq.lab.eng.bos.redhat.com/pub/rhel_incre/
[.........................................................................................................................................................................................................] [100%]
New packages: 2 (5.53 KB).

# hammer repository synchronize --id 2 --incremental 1 --source-url http://qeblade36.rhq.lab.eng.bos.redhat.com/pub/cust_incre/
[.........................................................................................................................................................................................................] [100%]
New packages: 2 (5.56 KB).


So moving this to Verified !

Comment 18 pulp-infra@redhat.com 2016-07-12 20:31:36 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 19 Bryan Kearney 2016-07-27 11:26:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.