Bug 1326941 - content view publish creates extra metadata generation task, slowing publish time
Summary: content view publish creates extra metadata generation task, slowing publish ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Performance
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Chris Duryee
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-13 19:52 UTC by Chris Duryee
Modified: 2019-09-26 16:21 UTC (History)
3 users (show)

Fixed In Version: rubygem-katello-3.0.0.18-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:08:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14628 'Normal' 'Closed' 'content view publish creates extra metadata generate task' 2019-11-14 16:56:20 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Chris Duryee 2016-04-13 19:52:45 UTC
Description of problem:

As part of the "run" phase of a Katello repo create, it will tell Pulp to do a publish. This is needed in order to fill in the repo immediately, so consumers don't get a 404 in between the time when the user creates the repo in the web UI, and when Pulp does the publish after unit association.

However, when cloning repos, there's no need to do this extra publish. In fact, it can lead to slowness since there's now two publishes happening instead of one.

Version-Release number of selected component (if applicable): 6.2.0 beta snapshot


How reproducible: every time


Steps to Reproduce:
1. sync a large repo (rhel 6 server is a good one)
2. create CV, add repo, publish CV version

Actual results: YMMV, but this can take about five minutes

Expected results: 3-ish minutes

Additional info: If you perform the publish and look at the tasks list, you'll see a "metadata generate" task owned by foreman_api_admin user. This is the task that should go away for CV version publishes.

Also note: this is one issue related to slow CV publish, but there may be other areas that could use optimization.

Comment 2 Bryan Kearney 2016-04-13 20:03:12 UTC
Upstream bug component is Performance

Comment 3 Bryan Kearney 2016-04-14 14:03:29 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14628 has been closed
-------------
Chris Duryee
Applied in changeset commit:katello|d2df121200636ea86d93bdf5305500646f6863f3.

Comment 4 Roman Plevka 2016-04-18 08:13:42 UTC
VERIFIED
on sat 6.2.0 snap 8.1

there's no 'metadata generate' task for CV publish any more.

<task-id>| | admin | 2016/04/18 08:04:04 | 2016/04/18 08:04:04 | stopped | success | Sync Capsule with Content View
<task-id>| | admin | 2016/04/18 08:02:52 | 2016/04/18 08:04:04 | stopped | success | Publish
<task-id>| | admin | 2016/04/18 08:02:35 | 2016/04/18 08:02:35 | stopped | success | Update
<task-id>| | admin | 2016/04/18 07:58:52 | 2016/04/18 07:58:53 | stopped | success | Sync Repository on Capsule(s)
<task-id>| | admin | 2016/04/18 07:45:18 | 2016/04/18 07:58:54 | stopped | success | Synchronize
<task-id>| | admin | 2016/04/18 07:45:18 | 2016/04/18 07:58:54 | stopped | success | Synchronize
<task-id>| | foreman_api_admin | 2016/04/18 07:44:59 | 2016/04/18 07:45:01 | stopped | success | Metadata generate
<task-id>| | admin | 2016/04/18 07:44:57 | 2016/04/18 07:45:00 | stoppedd | success | Enable
...

Comment 6 errata-xmlrpc 2016-07-27 09:08:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.