Bug 1326948 - Incremental update failed when specifying multiple errata
Summary: Incremental update failed when specifying multiple errata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-13 20:41 UTC by sthirugn@redhat.com
Modified: 2019-09-25 21:18 UTC (History)
3 users (show)

Fixed In Version: rubygem-katello-3.0.0.18-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:31:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Apply errata page failure (126.58 KB, image/png)
2016-04-13 20:41 UTC, sthirugn@redhat.com
no flags Details
production.log error (13.97 KB, text/plain)
2016-04-13 20:41 UTC, sthirugn@redhat.com
no flags Details
production.log error (25.24 KB, text/plain)
2016-04-13 21:11 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14631 None None None 2016-04-22 16:40:46 UTC

Description sthirugn@redhat.com 2016-04-13 20:41:01 UTC
Created attachment 1146954 [details]
Apply errata page failure

Description of problem:
Incremental update failed

Version-Release number of selected component (if applicable):
satellite-6.2.0-7.0.beta.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. try to apply an incremental update selecting a few erratas (see screenshot)


Actual results:
Apply Errata page errors out:

ERROR: operator does not exist: integer = record LINE 1: ...* FROM "katello_errata" WHERE (katello_errata.id = (-1,-1,-... ^ HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts.

Expected results:
No error and inc update successful.

Additional info:

Comment 1 sthirugn@redhat.com 2016-04-13 20:41:49 UTC
Created attachment 1146956 [details]
production.log error

Comment 3 sthirugn@redhat.com 2016-04-13 21:11:38 UTC
Created attachment 1146970 [details]
production.log error

Comment 4 Justin Sherrill 2016-04-13 21:27:42 UTC
Created redmine issue http://projects.theforeman.org/issues/14631 from this bug

Comment 5 Brad Buckingham 2016-04-14 13:47:36 UTC
Triaging and moving to POST, since fix is merged upstream.

Comment 6 jcallaha 2016-04-22 18:42:52 UTC
Verified in Satellite 6.2 Beta Snap 9. Multiple errata are now able to be applied as expected.

Comment 8 errata-xmlrpc 2016-07-27 09:31:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.