Bug 1326957 - Couldn't import dot_parser
Summary: Couldn't import dot_parser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-networkx
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-13 22:26 UTC by Volker Fröhlich
Modified: 2016-04-30 23:53 UTC (History)
1 user (show)

Fixed In Version: python-networkx-1.11-3.fc24 python-networkx-1.9.1-5.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-30 23:53:47 UTC


Attachments (Terms of Use)

Description Volker Fröhlich 2016-04-13 22:26:35 UTC
Description of problem:

Importing the module causes a warning

Steps to Reproduce:
1. dnf install python-networkx
2. python -c "import networkx"

Actual results:

Couldn't import dot_parser, loading of dot files will not be possible.

As far as I understand it, pydot does not work with pyparsing 2. So, I guess this dependency should be removed no matter what. A suitable replacement for 1.0.9 seems to be python-graphviz. Using python-graphviz instead after removing pydot (ignoring dependencies) seems to do the actual job. Other implementations appear to be supported in 1.10, but not 1.9.1: "PYDOT_LIBRARIES = ['pydot', 'pydotplus', 'pydot_ng']"

https://networkx.github.io/documentation/latest/_modules/networkx/drawing/nx_pydot.html

pydotplus is available in Fedora.

Comment 1 Volker Fröhlich 2016-04-13 22:33:38 UTC
For whatever reason, this problem does not appear in Debian Jessie.

Comment 2 Fedora Update System 2016-04-15 04:36:31 UTC
python-networkx-1.9.1-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5da2b99655

Comment 3 Fedora Update System 2016-04-15 04:36:39 UTC
python-networkx-1.11-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da24f0cd71

Comment 4 Fedora Update System 2016-04-15 23:22:21 UTC
python-networkx-1.11-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-da24f0cd71

Comment 5 Fedora Update System 2016-04-19 20:31:11 UTC
python-networkx-1.11-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2016-04-22 20:58:43 UTC
python-networkx-1.9.1-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5da2b99655

Comment 7 Fedora Update System 2016-04-30 23:53:45 UTC
python-networkx-1.9.1-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.