Bug 1326985 - Frequent "sedispatch: timeout flush" log messages
Summary: Frequent "sedispatch: timeout flush" log messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 23
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-14 01:39 UTC by Michael Chapman
Modified: 2016-04-19 19:22 UTC (History)
4 users (show)

Fixed In Version: setroubleshoot-3.3.5-3.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-19 19:22:36 UTC


Attachments (Terms of Use)

Description Michael Chapman 2016-04-14 01:39:07 UTC
Description of problem:

sedispatch logs "timeout flush" at LOG_ERR severity level after most audit messages. This can be quite frequent at times:

Apr 14 11:25:00 example.com audit[7154]: USER_START ...
Apr 14 11:25:36 example.com audit[7154]: USER_END ...
Apr 14 11:25:36 example.com audit[7154]: CRED_DISP ...
Apr 14 11:25:39 example.com sedispatch[1098]: timeout flush
Apr 14 11:25:42 example.com sedispatch[1098]: timeout flush

This appears to be caused by commit https://github.com/bachradsusi/setroubleshoot/commit/352a3b954b66e2e69abdf22455255571c0411d32 to fix this bug 1322771.

In my opinion this log message is unnecessary; it provides no useful information for the system administrator. If the log message must be there at all, it would be better if it were logged at LOG_DEBUG severity level.

Version-Release number of selected component (if applicable):

setroubleshoot-3.3.5-1.fc23.x86_64

Comment 1 Petr Lautrbach 2016-04-14 08:27:32 UTC
It's unintentionally left debugging message. It'll be removed in the next update. Thanks for the report!

Comment 2 Fedora Update System 2016-04-14 10:13:00 UTC
setroubleshoot-3.3.5-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-31f74d4283

Comment 3 Fedora Update System 2016-04-14 10:13:55 UTC
setroubleshoot-3.3.5-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5727d14751

Comment 4 Fedora Update System 2016-04-15 08:37:31 UTC
setroubleshoot-3.3.5-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-31f74d4283

Comment 5 Fedora Update System 2016-04-16 19:26:13 UTC
setroubleshoot-3.3.5-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5727d14751

Comment 6 Fedora Update System 2016-04-18 17:25:44 UTC
setroubleshoot-3.3.5-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-04-19 19:22:34 UTC
setroubleshoot-3.3.5-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.