Bug 132702 - rpmbuild resolves dependancies when removing source package
rpmbuild resolves dependancies when removing source package
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 21:31 EDT by Peio Popov
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 03:02:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peio Popov 2004-09-15 21:31:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040612 Firefox/0.8

Description of problem:
When removing source rpm packages build dependancies (BuildPrereq) are
resolved and if they are not present the package can not be removed.

Example:
[root@fedora SPECS]# rpmbuild --rmsource --clean  postfix.spec
error: Failed build dependencies:
        db4-devel is needed by postfix-2.0.18-4
        ....
        openssl-devel >= 0.9.6 is needed by postfix-2.0.18-4

In my opinion when somebody is trying to remove a source package or
clean the build root the build perequisites are not used and required.



Version-Release number of selected component (if applicable):
rpm-build-4.3.1-0.3_27.rhfc2.at

How reproducible:
Always

Steps to Reproduce:
1. Remove some or all *devel* packages.
2. Install any src.rpm package
3. Try to remove it using rpmbuild.
    

Actual Results:  The sources, the build root and the .spec file could
not be removed because of failed dependancies.

Expected Results:  I would expect that if I am not able to build the
package I should have the ability to remove it. 


Additional info:

If I comment the BuildPrereq it would act as expected:
sed -i~ -e �s/^BuildPrereq/#BuildPrereq/� packet.spec
Comment 1 Jeff Johnson 2004-09-16 03:02:33 EDT
Add --nodeps to disable.
Comment 2 Peio Popov 2004-09-16 08:32:35 EDT
Thank you and sorry for the unnecessary report. 
The --nodeps option is not in the man page for rpmbuild and thats why
I haven't tried it.

Thank you once again.

Note You need to log in before you can comment on or make changes to this bug.