Bug 1327052 - Glusterfs write meta data to normal file which cause file crashed
Summary: Glusterfs write meta data to normal file which cause file crashed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.6.9
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-14 07:43 UTC by coyang
Modified: 2016-04-27 01:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-27 01:18:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
detailed log when problem happen (1.81 MB, application/x-ole-storage)
2016-04-14 07:43 UTC, coyang
no flags Details

Description coyang 2016-04-14 07:43:13 UTC
Created attachment 1147059 [details]
detailed log when problem happen

Description of problem:
We found file is crashed in glusterfs brick, some glusterfs specific meta data is written to file. 

Version-Release number of selected component (if applicable):
we found the problem exist in glustfs 3.6.9, 3.7.2 and 3.7.6

How reproducible:
Env config description:
2 VM for glusterfs client + 3 storage nodes.

Steps to Reproduce:
1.in host use "nova stop" shutdown VMs in sequance
2.use "nova start " to startup VM
3. check system startup status
4. repeat step 1~ 3 

Actual results:
After some rounds, we found some file is crashed and file is replaced by glusterfs metadata (include some glusterfs gid)

Expected results:
file is not changed

Additional info:

in attachment.

Comment 1 Soumya Koduri 2016-04-19 12:33:34 UTC
Do you mean brick process crashed? I am unable to open the attached log file. Could you please provide core (bt).

Comment 2 coyang 2016-04-27 01:18:15 UTC
Hi,
Sorry for late reply.
Please close this bug, it's not a bug in glusterfs.
The root cause is in guest VM kernel config where the graceful shutdown of VMs by openstack does not work properly. 
With correction of kernel, the problem is fixed.
Thank you very much for your kindly check.



br,
Yang Congxue


Note You need to log in before you can comment on or make changes to this bug.